iTunes starting in 32bit mode (SOLVED)

Discussion in 'Mac Basics and Help' started by Puppybasher, Jun 2, 2010.

  1. Puppybasher macrumors newbie

    Joined:
    Mar 14, 2010
    #1
    I was messing around with Audio Hijack and it was working just fine. But now it seems iTunes always starts in 32-bit mode (even without audio hijack running). Also it seems to take quite a while to open the app.

    If I log in as root (or via a Terminal) I can open iTunes just fine, 64-bit and it opens instantly.

    Also when I log out OS X hangs a while on the screen you get when he's logging you out (the blue-ish screen)

    Does anybody have a clue how I can fix this?

    Cheers!
     
  2. Menge macrumors 6502a

    Menge

    Joined:
    Dec 22, 2008
    Location:
    Amsterdam
    #2
    iTunes is 32bit only. It takes longer on your user because you actually have stuff added to your library.
     
  3. Puppybasher thread starter macrumors newbie

    Joined:
    Mar 14, 2010
    #3
    but if I run it as root and look in the activity monitor it says (Intel 64-bit) and when I don't run it as root it doesn't + It never took so long to open before I used Audio Hijack

    Edit:
    Hmmmm seems im wrong. Sorry about that. Nevertheless the logging out seems quite weird + itunes doesnt connect / sync my iphone

    Edit 2:
    Ok.. a reboot seemed to solve the problem
     

Share This Page