iTunes Store is currently unavailable

Discussion in 'Apple TV and Home Theater' started by jahlinux, Mar 21, 2015.

  1. jahlinux macrumors member

    jahlinux

    Joined:
    Jul 18, 2008
    #1
    Purchased the season of "Reign" and watched all the old episodes without any issues. The newest episode "Tempting Fate" shows up but will not play on the Apple TV. When selecting it I get the following error: "The iTunes Store is currently unavailable. Try again later." This has been going on since March 20th. All other iTunes Store content loads and plays without any issues. This is happening on both of my Apple Tv's. I have restarted the modem, restarted the Time Capsule, logged in and out of the Apple ID, restored one of the Apple Tv's, unplugged them, used my wife's Apple ID, noting works. I was not able to play the episode using AirPlay on my MacBook Pro get the following error: "This movie can be played only on displays that support HDCP (High-bandwidth Digital Content Protection), but we were able to watch it using AirPlay on my iPad.

    Anyone have any ideas on what may be causing this problem?
     
  2. Soulweaponry macrumors 6502

    Joined:
    Mar 13, 2010
    #2
    [​IMG]

    I feel your pain bro. I'm not getting any answers from anybody like this problem doesn't exist. I have a season pass for 3 different shows that I can't watch on either of my Apple TV now.
     
  3. ABC5S Suspended

    ABC5S

    Joined:
    Sep 10, 2013
    Location:
    Florida
    #3
    Unknown if this is the problem but, if you wish you can take the Apple TV, and hook it up to a computer to reset the whole darn thing over again, than had to insert your email and passcode again after hooking it back up to my TV. Might just be your issue. iTunes store is working for me.

    A few things you can try below....

    http://www.iphonetopics.com/apple-tv-cannot-connect-to-itunes-store/
     
  4. benh911f macrumors 6502

    Joined:
    Mar 11, 2009
    #4
    I had this happen to me last week with Better Call Saul, and the only workout I came up with to finally get the newest episode to play was to go in the iTunes Store on the ATV and play it from there. Very frustrating, but at least in the meantime I was able to watch the show.
     
  5. Soulweaponry macrumors 6502

    Joined:
    Mar 13, 2010
    #5
    Now it's not doing that anymore on my Apple TV. I think it was probably an issue of apple engineers not updating the code that linked the text you click on for next episode to an actual episode from the purchased section.

    My workaround was to just search it on iTunes and play it.
     
  6. jahlinux thread starter macrumors member

    jahlinux

    Joined:
    Jul 18, 2008
  7. twobelowpar macrumors regular

    Joined:
    Dec 7, 2013
    #7
    Tried to watch Interstellar last night. Nope. Tried Unbroken. Worked for 10 minutes. Ended up watching Disney Nature Bears...
     

Share This Page