Itunes Store On G4 is Kaput

Discussion in 'Apple, Inc and Tech Industry' started by hwydude, Oct 27, 2011.

  1. hwydude macrumors newbie

    hwydude

    Joined:
    Oct 27, 2011
    Location:
    Oregon
    #1
    Sad G4 locked out of using Itunes Store. Add comes up to download itunes 10 which I am sure requires intel not G4
     
  2. iParis macrumors 68040

    iParis

    Joined:
    Jul 29, 2008
    Location:
    New Mexico
    #2
    You probably don't have Leopard, I'm assuming.

    From the iTunes page on Apple's website:

     
  3. roadbloc macrumors G3

    roadbloc

    Joined:
    Aug 24, 2009
    Location:
    UK
    #3
    I find it interesting how you can still run the latest iTunes on a 10 year old XP box, and yet old OS X users are now finding it next to impossible.

    I do wish Apple would support their products for longer. I really do.
     
  4. RawBert macrumors 68000

    RawBert

    Joined:
    Jan 19, 2010
    Location:
    North Hollywood, CA
  5. velocityg4 macrumors 68040

    velocityg4

    Joined:
    Dec 19, 2004
    Location:
    Georgia
    #5
    What I don't get is why Apple would care what version of iTunes you are running if you are just purchasing music off their store or any other content your version is compatible with.
     
  6. AdrianK macrumors 68020

    Joined:
    Feb 19, 2011
    #6
    You know what also sucks: Star Wars Special Editions.
     

Share This Page