iTunes TV show playback error

Discussion in 'Mac Apps and Mac App Store' started by MotoMaster, Dec 20, 2011.

  1. MotoMaster macrumors newbie

    Joined:
    Jan 24, 2010
    #1
    Hey Guys/Gals,

    I am having an issue with iTunes when I try to play my TV shows that I have purchased. Every time I try to play one I get this message:

    [​IMG]

    I follow the [More Info...] button to an Apple Support document. I read through the article and understand what it is saying. I follow the steps and it works, however when I run iTunes in 32-bit mode it runs very slowly, so I switch back to 64-bit mode and the files seem to work. :confused: Having to do this is very tedious when a new show downloads. I would just like it to work right away.

    My questions are:

    Does anyone know why this is happening?
    How do I correct this?
    Why is it that iTunes think the new shows are an old file type?

    To help in the situation my hardware and software is the following:

    MacBook Pro 17", Early 2008
    Processor - 2.6 GHz Intel Core 2 Duo
    Memory - 4 GB 667 MHz DDR2 SDRAM
    Graphics - NVIDIA GeForce 8600M GT 512 MB
    Software - Mac OS X Lion 10.7.2 (11C74)
    - - - - - - - iTunes 10.5.2 (11) 64-bit
    - - - - - - - QuickTime 10.1 (501.5)


    Thank you for your time at looking at this. :)
     
  2. DraziGuy macrumors member

    Joined:
    Oct 20, 2009
    #2
    Unfortunately I don't have a solution, but I had exactly the same problem. Episodes of The Daily Show, purchased from iTunes in December, were randomly not playing with that same error message. A conversation through email with iTunes support was completely unproductive. I never got an answer back as to what was causing the issue, but they did credit me for all the episodes that were refusing to play. I tried to get the support agents to escalate the problem as it was just a problem with the user, I felt, but a problem with the encoding of the files themselves. They just fobbed me off with the credits after trying to get me to re-download the episodes a few times. I switched to 32 bit and the problem disappeared, though luckily for me I don't have any performance problems with 32 bit as you seem to be having.
     

Share This Page