itunes unexpectedly quit and won't open!

rkw0704

macrumors newbie
Original poster
Nov 21, 2009
5
0
My itunes randomly, even after several restarts and re-installations, won't open and always says that itunes has "unexpectedly quit". Please help I don't know what to do.

This is what the error reads:

Process: iTunes [595]
Path: /Applications/iTunes.app/Contents/MacOS/iTunes
Identifier: com.apple.iTunes
Version: ??? (???)
Build Info: iTunes-9022501~2
Code Type: X86 (Native)
Parent Process: launchd [98]

Interval Since Last Report: 241 sec
Crashes Since Last Report: 1
Per-App Interval Since Last Report: 0 sec
Per-App Crashes Since Last Report: 1

Date/Time: 2009-11-21 17:36:53.095 -0500
OS Version: Mac OS X 10.5.8 (9L31a)
Report Version: 6
Anonymous UUID: B7259C58-E7A6-4DE2-92A8-D05B2E2A2F3B

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Symbol not found: __ZNK3JSC6JSCell17getTruncatedInt32ERi
Referenced from: /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore
Expected in: /System/Library/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCore
 

rkw0704

macrumors newbie
Original poster
Nov 21, 2009
5
0
my ichat, iphoto, skype, safari....nothing will open they all have the same error.

Dyld Error Message:
Symbol not found: __ZNK3JSC6JSCell17getTruncatedInt32ERi
Referenced from: /System/Library/Frameworks/WebKit.framework/Versions/A/Frameworks/WebCore.framework/Versions/A/WebCore
Expected in: /System/Library/Frameworks/JavaScriptCore.framework/Versions/A/JavaScriptCor


this all happened after my computer did some kind of software update

I don't know what to do :(
 

Anonymous Prime

macrumors newbie
Jan 12, 2010
1
0
Try reinstalling Safari.

I had a similar problem today, with apps crashing on launch, and with similar stuff in the crash reports-- I found this thread by Googling for "Symbol not found: __ZNK3JSC6JSCell17getTruncatedInt32ERi"

and I also found this:
http://www.meproxsoft.de/tag/time-machine/

I can barely make out "repair permissions" and "reinstall Safari" from that, and the latter worked for me. It reinstalled the Webkit and JavascriptCore frameworks along the way. Apparently, those are the problem. I still don't know what caused them to break like they did, though.
 

Similar threads

  • sfphoto
0
Replies
0
Views
71
  • dcmaccam
3
Replies
3
Views
371
  • licalica
0
Replies
0
Views
267
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.