iTunes Unknown Error (2001) - Classic's Fault!

Discussion in 'iPod touch' started by TheSpaz, Mar 3, 2008.

  1. TheSpaz macrumors 604


    Jun 20, 2005
    Unknown Error (2001)

    If you keep getting this error, it won't matter how many times you turn off and turn on your iPod touch, you will always get this error in iTunes while trying to restore. Well, today after fighting with my iPod, I was getting this error trying to update to 1.1.4 (not jailbroken or anything)

    Here's how I fixed it. I noticed Classic was running (Tiger 10.4.11) so I just quit Classic and without doing anything else, I re-clicked the update button in iTunes and it worked! Come to think of it... when I was having this problem this morning, I had Classic running then too but, I didn't know that was the culprit. This morning when I upgraded to 1.1.3 I kept getting the (2001) error so I restarted my computer (thus stopping Classic from running)... so that's gotta be the problem! Stop Classic and everything will work! Can anyone else confirm this? Run Classic and try restoring their iPod and see if they get error (2001). Then quit Classic and try again and see if it works.

Share This Page