iTunes version 9.2 no longer 'talks' with ipod Classic?

Discussion in 'Mac Basics and Help' started by GilesM, Jul 15, 2010.

  1. GilesM macrumors 6502

    Joined:
    Oct 17, 2008
    #1
    Hello

    I have just encountered an issue with iTunes 9.2 and my ipod classic (120 GB model).
    Itunes 'sees' the ipod when first plugged in for a brief while, all appears normal, icon appears on the desktop and in itunes, then the ipod will be ejected after a short while.
    I have performed a reboot of the ipod, and of the iMac and of iTunes 9.02.

    Nothing has done any good.
    Just prior to this I was attempting to Synchronize the ipod, the last attempt caused iTunes to crash and I had to force quit.

    Now the ipod just gets ejected after 10 seconds or so of being connected, and in iTunes the ipod still shows as connected when is not.


    When connected to my wife's iMac (same software revisions) all seems OK.
    I have moved the iPod to another USB port, direct connected, not running through a hub. Same issue remains.

    If i connect the iPod but do not launch iTunes, all is ok, the iPod mounts perfectly.
    Once iTunes ejects the iPod, it remains in the Devices section of iTunes window.
    Charging continues once the ipod is 'ejected'.

    I saw iTunes attempt to verify the ipod. I think this verification is failing, but the ipod is fine on my wife's iMac.




    Any ideas? Reset for the ipod perhaps?

    Imac software is 10.5.8
    Ipod software is 2.0.1
     
  2. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #2
    Do you have a Time Machine backup prior to when the problems started? If so, perhaps try restoring iTunes from a backup to see if that helps.
     
  3. GilesM thread starter macrumors 6502

    Joined:
    Oct 17, 2008
    #3
    Well, just tried that, no good I am afraid.
    Everything is just the same.
    My library is on a USB hard drive, at least that is one advantage.
    If i go back too far in my 'Time Machine' then the restored version of iTunes will not work with my library which was updated by version 9.2
    Can I dismount the library restore to the old version without deleting everything on my Apple TV? hhmmmm
     
  4. GilesM thread starter macrumors 6502

    Joined:
    Oct 17, 2008
    #4
    Right, so it looks like your advice has helped me fix it.

    I had to restore iTunes from time machine (using the same version), then point the new iTunes at my library, then restore the ipod to factory settings.
    So now it works, but I have only put a few items on it so far.
    I want to run it for a while with just a few albums prior to placing 60GB of music on to it.

    Thank you for your help, I have fixed it but can not even guess why this happened....:eek:
     

Share This Page