iTunes wants to delete apps when I try to add photos

Discussion in 'iPod touch' started by semiartificial, Feb 28, 2011.

  1. semiartificial, Feb 28, 2011
    Last edited: Feb 28, 2011

    semiartificial macrumors newbie

    Joined:
    Feb 28, 2011
    #1
    Short general background:
    I'm very new to Apple, but my wife bought me an iPad at Christmas. iTunes was weird at first but I've managed to add various things, including photos.

    Problem:
    I've now got an old iPod touch. I set iTunes up on another computer, using a different account. Got some free apps, added music, books etc to itunes, synched, all fine.
    Then I tried to sync photos to a folder, but when I check the box next to 'sync photos from ...' at the top, the sync button at the bottom right is replaced by 'revert' and 'apply'.
    If I hit the 'apply' button, I get a message asking if I'm sure I want to delete apps (which I don't). So, I can't add photos.
    I noticed that when I go to the apps tab, the content is grey, I can't change anything, but the 'sync' button works ok.
    I haven't tried to jailbreak it or anything dodgy!

    I would be very grateful if someone could explain why it's doing this and how I can fit it so I can get some photos onto it.

    Thanks.
     
  2. Brucewl macrumors 6502

    Brucewl

    Joined:
    Sep 15, 2010
    #2
    Your iTunes account, I suggest you to change your account to the previous one.
     
  3. semiartificial thread starter macrumors newbie

    Joined:
    Feb 28, 2011
    #3
    Thanks for the reply.

    Could you please explain why this would help.
    I'm not great with computers, but does iTunes/Apple try to link things to an IP address or something?
     
  4. semiartificial thread starter macrumors newbie

    Joined:
    Feb 28, 2011
    #4
    Ok, for anyone else who gets a similar problem, here's how I ended up.

    I saw advice else where to right-click the ipod when connected to iTunes and 'transfer purchases' and then simply try again with the photos but say that I accept the apps being deleted.

    I thought that the worst that can happen here is that I have to install a bunch of free apps again, so decided to go for it.

    Nothing much happened when I hit 'transfer purchases'.

    I then opted to delete my apps and hoped for the best.
    15 seconds later it was all over.
    Sync complete (there was only one photo, just as a test).
    No apps lost.
    And the apps aren't grey now in iTunes.
    Everything seems fine.
    Got some more photos on, everything sync'ing ok.

    Seems I wasted several hours of my life researching this problem - thanks iTunes - but a relatively happy ending.
     

Share This Page