"iTunes was unable to load dataclass information from Sync Services....

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cubixx, Jul 17, 2008.

  1. cubixx macrumors newbie

    Jul 17, 2008
    "iTunes was unable to load dataclass information from Sync Services.
    Reconnect or try again later"

    I JUST updated to the 2.0 firmware on iphone. and it won't sync.... i noticed many people have this problem. and no one has solved this yet. IF someone did solve it... i missed it. help please....

    0. i originally started with 1.1.4 firmware jailbroken iphone.

    1. i jailbroke my iphone using ziphone (i have at&t and did NOT unlock it...just jailbroken) then from the ziphone i used the button that readys the iphone for a update...

    2. went into itunes, had some random error that wouldnt allow me to fully download the 2.0 update.. problem was fixed by disabling my firewall/antivirus.. then downloaded/installed the 2.0 firmware.

    3. all looks good. but when i hook it up to itunes... it shows the error
    "iTunes was unable to load dataclass information from Sync Services.
    Reconnect or try again later" ...

    4. on the left side of itunes.. it shows that my iphone is connected... when i click it.. it shows nothing...just blank page or a copy of my itunes library..
    -there is no buttons to click that says restore or sync.. just that stupid error..

    5. right before the 2.0 update.. i did backup my iphone.. so i have all the backups saved.. just...it won't sync with itunes anymore... + now all my contacts are gone/ music/ photos until this stupid error is solved.

    HELP PLEASE. ... thats enough detail...kmon lol.

    please respond and keep this post going until problem is fixed.. for me and the many others who have this random dumb problem... STUPID 2.0... -.- uggh
  2. andrewstill macrumors newbie

    Jul 25, 2008
    same thing is happening to me and i have no idea what to do because i tried everything the apple forums said and it still gives me the error message wtf
  3. ssowy macrumors newbie

    Jul 11, 2008
  4. vakanderson macrumors newbie

    Jun 25, 2009
    iTunes 8.2.1 fixed it for me

    Had tried all the tips on my Leopard iMac, and it wasn't until 8.2.1 that it started working.
  5. nixie1094 macrumors newbie

    Feb 15, 2010
    easier then it seems

    I just ran into this problem and after serching for the answer on google i started stressing out thinking im going to have to reload my iphone and re sync everything but before you do what i was about to do...try the following! the simplest thing possible that is a long shot but for some reason worked for me; unplug the device, shut itunes, restart the device, re-open itunes and try to sync one more time before you get technical, you may be verry suprised as i just was!
  6. gikku macrumors regular


    Dec 29, 2006
    argh! iPad kills iTunes, now iPhone doesn't sync anymore either.

    activated iPad and killed iTunes now i get
    "iTunes was unable to load dataclass information from Sync Services"
    when trying to sync iphone, ipad.

    no end of rebooting, reinstalling Apple Mobile Device Service, downgrading to iTunes 9.1, 8.2 back to 9.1.1 seems to work.
    No more sync for me.
  7. Clete2 macrumors 65816


    Sep 20, 2008
  8. thisgarryhas2rs macrumors newbie

    Mar 15, 2011
    If you recently added your device as a "Development" device in Xcode, that might be the reason. I just added my device and got that error. When I removed my device from the Xcode Organizer and it started working again.

    Hope that helps.
  9. BugDave macrumors newbie

    Nov 17, 2003
    me three! :D
  10. tbox macrumors newbie

    May 15, 2008
    I did not get the same happy result after removing the device from the new x-code organizer. Both of my devices initiate the same error message in iTunes 'unable to load data class information from sync services' This error is displayed 10 secs after plugging in the device to a USB port. very odd....
  11. BugDave macrumors newbie

    Nov 17, 2003
    I guess my post wasn't clear :-/ I followed ssowy's recommendation as did Clete2 who I was saying me three too. Here is what ssowy said
  12. tbox macrumors newbie

    May 15, 2008
    ok, issue resolved after 8 reboots using the info on http://support.apple.com/kb/TS3540
  13. jason1790 macrumors member

    Apr 27, 2010
    Iowa City, IA
    If you go to the Apple link above and follow all the steps will it delete any of my Music, videos, apps, etc?
  14. tbox macrumors newbie

    May 15, 2008
    it may wipe your own short term memory clean but it won't touch your music.
  15. Nathe macrumors member

    Feb 25, 2011
    Staffordshire, UK
    This link fixed it for me also, thanks, that was driving me nuts! :mad:
  16. Jethrotoe, Mar 31, 2011
    Last edited: Apr 1, 2011

    Jethrotoe macrumors regular

    May 24, 2009
    Somewhere over there.
    Problem solved.

    Well, it seems like I'm having a similar problem as some here but a little different.

    I just installed an upgrade to Xcode and I'm getting the '...unable to load data class info...' error when syncing my iPhone. It was previously listed as a development device and remained listed after the upgrade.

    Here is where my situation differs. I can sync. New pod casts load and all. What it won't do is backup. It tries to backup first, fails, and I get the stated error. I click OK and then syncing resumes and completes. I do get an additional error stating backup failed at the end.

    I tried removing the device from Organizer as you mentioned but there is no change with the problem.

    I checked out a few of the links in this thread but they seem to slant towards an iTunes problem where mine seems to have been generated from Xcode.

    Sure could use some help here or some ideas to try. Perhaps a Dev that knows Xcode better than I do. Tks.

    I fixed my problem following these instructions: http://support.apple.com/kb/HT1747

    My problem was from an Xcode upgrade but fixed with an iTunes re-install.
    I still have to add my devices (iPhone and iPad) as a development devices. Hope it doesn't happen again.

    BTW, for anyone with this problem that is hesitant to delete and re-install iTunes, the method I used (see link) preserved everything, ie. music, pod casts, etc. I never had to do this and was uncertain but it works well.
  17. deadkennedy macrumors 6502

    May 22, 2010
    Just to add that this issue is still not resolved as of April 2011, which is roughly two years from the start of this thread.

    I managed to solve the issue by following this 76 step instructions to uninstall iTunes - http://support.apple.com/kb/ht1224, and trying again.

    Funny, I never had this problem with iPhone 3GS on Windows. Makes me want to put "Everything just works" in my sig line.
  18. thanson macrumors newbie

    Jul 7, 2011
    Just fyi this solution worked for me too.

    Brand new iPad2, sync'd with a Mac Mini with Xcode 4 installed..

Share This Page