iTunes will not sort soundtracks on my iPhone

Discussion in 'Mac Basics and Help' started by MaxBurn, Jun 19, 2011.

  1. MaxBurn macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #1
    First off I HAD this working before I erased my library file. I didn't lose any media but I did rebuild my library for iTunes. All the tags still seem to be in place, they just don't group on the iPhone anymore.

    Goal: on the iPhone I want a soundtrack like Natural Born Killers to show up as ONE entry Natural Born Killers under the iPhone Artists selection.

    I thought that simply entering in an Album Artist and marking as a compilation would do it, but it no longer works.

    What I have now:

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
     
  2. MaxBurn thread starter macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #2
    Anyone? My previous understanding was that this was the whole reason for the "album artist" field. Whole album would show up under that artist. Works in iTunes anyway but doesn't on the phone.
     
  3. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #3
    For iTunes to sort an album together, all tracks must have identical information in the following fields:
    • Album
    • Sort Album (this may be empty)
    • Album Artist
    • Sort Album Artist (this may be empty)
    However, if you sort your music by Artist, rather than Album Artist, the tracks made by different artists will not sort together.
     
  4. MaxBurn thread starter macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #4
    On the phone I don't see an option to sort between "artist" verses "album artist" and I don't remember doing that before.

    Really don't care one bit how iTunes displays content but currently it is showing that album all together as in my screenshot above.
     
  5. jep0617 macrumors newbie

    Joined:
    Mar 3, 2012
    #5
    Has there been an answer for this? I can get the soundtracks to appear the way I want them to in iTunes, but not on my iPod. Thanks
     
  6. MaxBurn thread starter macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #6
    I gave up and butchered my MP3 metadata and called the artist column Natural Born Killers in the example above.

    I already keep two copies of all my music, the archive backup copy and the copy that is modified to please iTunes so this was a non issue to me.

    This is still a disgusting hatchet job of a solution though.

    I would like to hear from someone that actually downloaded the above example through the iTunes music store to see if they had the same problem. I'm tempted but it's $12 I don't need to spend to get the same content again. I suspect it does the same thing anyway due to the mobile devices sorting by the artist field. Sorting by album sort of does it but I see more than I really need to, many artists I have have a lot of albums.
     
  7. MaxBurn, Mar 3, 2012
    Last edited: Mar 3, 2012

    MaxBurn thread starter macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #7
    Actually I do see a group by album artist in settings now. I don't know if that's an iOS 5 addition or not. If it isn't it was already on for me anyway.
     
  8. jep0617 macrumors newbie

    Joined:
    Mar 3, 2012
  9. MaxBurn thread starter macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #9
    I don't know if group by album artist in settings fixes it, try it and let us know.

    I have already changed my metadata to force it to work the way I wanted it to. In the artist field on the right I replaced the assorted artists with the album artist, it is a quick edit in itunes and of course it does fix this situation as all the artists are the same now.

    http://i255.photobucket.com/albums/hh157/scottjalbert/iTunes/NBK.png
     
  10. jep0617 macrumors newbie

    Joined:
    Mar 3, 2012
    #10
    In what settings? Don't have a setting for that on my iPod, and don't see it in iTunes either.
     
  11. MaxBurn thread starter macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #11
    Settings > music.

    In there with the EQ and volume limit.
     
  12. jep0617 macrumors newbie

    Joined:
    Mar 3, 2012
    #12
    I don't have that in settings. I have music menu which changes what options are listed in the music menu. I have Sort by which changes the way contacts are listed and the only choices are first & list.
     
  13. MaxBurn thread starter macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #13
    You don't have this? You on 5.0.1? Mine is a 4s but that shouldn't matter for this I would think. It sounds like what we were looking for, but I would have to go back and fix my data to see.

    [​IMG]
     
  14. jep0617 macrumors newbie

    Joined:
    Mar 3, 2012
    #14
    Ok, my bad. I do have a 4s, but I am talking about my iPod. Sorry. Any advice there?
     
  15. MaxBurn thread starter macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #15
    If it isn't a touch then I have nothing.

    Just edit the artist fields to be the same as album artist to force it. Back your correct music somewhere else first so you can go back easily.
     
  16. jep0617 macrumors newbie

    Joined:
    Mar 3, 2012
    #16
    That's basically what I did. I figure if I really want to know who the artist is on a specific track it's easily google-able & if it want to get the correct tags I can edit them myself or just re-download it. Thanks for caring :)
     

Share This Page