iTunes won't allow me to play or import an inserted CD

Discussion in 'Mac Apps and Mac App Store' started by Big Byte, Aug 5, 2010.

  1. Big Byte macrumors regular

    Joined:
    Jul 7, 2009
    #1
    Hi everyone,

    I recently updated iTunes to 9.2.1(4). Today I tried inserting a CD to import. iTunes accessed the database to retrieve the relevant song information but, once it did, I was no longer given the option to play or import the CD. During the access period, iTunes would briefly change to the artist/album/track, etc. information page for the CD but, once the access was finished, I could not access the CD, which didn't even show up on the side bar as it used to. Anyone know what the problem is and how I can resolve it? Thanks.
     
  2. theLimit macrumors 6502a

    theLimit

    Joined:
    Jan 30, 2007
    Location:
    up tha holler, acrost tha crick
    #2
    Is it a retail CD? It may have some copy protection.

    Have you tried any other rippers? AudialHub is one that I've used, but it's been discontinued.

    The title of the CD may help someone offer more advice.
     
  3. Big Byte thread starter macrumors regular

    Joined:
    Jul 7, 2009
    #3
    Thanks for the reply. It is a retail CD (which are the only types of CDs that I burn). Specifically, it is a Columbia release of Mahavishnu Orchestra's "Birds of Fire"). I have not tried any other rippers, just the burner that comes with my Mac (and which I have not had any problems with up to now). I think I will try another CD to make sure it is not the burner.
     

Share This Page