iTunes won't import ANY movies

Discussion in 'Mac Apps and Mac App Store' started by magda71, Apr 24, 2015.

  1. magda71 macrumors newbie

    Joined:
    Dec 21, 2014
    #1
    I'm losing it and I'm sure there MUST be an easy way to do this and I MUST be doing something wrong but WHAT???
    I have a number of shows for my little girl that I want to add to my iTunes library and then put on my iPod. They are mainly - but not all - avi files. I have converted them using Handbrake as well as other converters. When using Handbrake, I have tried to use the universal preset as well as the ipod preset. I have tried renaming the extension to make it a .mov file. I have tried importing using "add to library" in iTunes and I have tried dragging into iTunes (when I drag, iTunes is highlighted like all is going well), but I simply can NOT get iTunes to import ANYTHING!
    PLEA-EA-EASE help!!!
     
  2. PsyOpWarlord macrumors 6502

    PsyOpWarlord

    Joined:
    Nov 11, 2010
    Location:
    Colorado Springs, CO
    #2
    I make all my content .mp4

    Have you tried dropping the file into the folder "/iTunes/Automatically Add to iTunes"

    Also in iTunes when you go to movies check the Home Videos tab. There is the possibility that it was moving all your movies into that area.
     
  3. phrehdd macrumors 68040

    phrehdd

    Joined:
    Oct 25, 2008
    #3
    I don't recall off hand, but does iTunes have limits to actual file size? I am more or less asking rather than stating. If yes, then have you check to see if the size of your files fall within iTunes requirements?
     
  4. magda71 thread starter macrumors newbie

    Joined:
    Dec 21, 2014
    #4
    Thanks all.

    I did try dropping into the "Automatically Add to iTunes". Didn't know anything about that folder but found it and tried dropping a couple of converted files. one in .m4v and one in .mov formats. Shut down iTunes and reopened it but neither file is there. Although they are still in the "Automatically Add to iTunes". Am I a complete idiot? Should I be doing something with them after dropping them in there.

    And yes, I've checked "My Movies", "Unwatched", "Home Videos"... nothing. I've done this before and succeeded so I already have a whole bunch in "Home Videos" but I can't for the life of me figure out what I'm doing wrong this time around!!
    Can't possibly be a size issue as have done this with Disney movies and all went well. BUt now I can't even get the tinniest file uploaded in iTunes.
    I do remember that there had been an issue before but that was something to do with unacceptable characters in the file names and I tried simplifying my current file names but no luck!

    This simply can't be THIS complicated!!
     
  5. magda71 thread starter macrumors newbie

    Joined:
    Dec 21, 2014
    #5
    Don't suppose anyone has any other suggestions?!?
    Still facing this problem!

    Thanks
     
  6. rctlr macrumors 6502a

    rctlr

    Joined:
    May 9, 2012
    #6
    I presume they playback ok in Quicktime?

    You've not moved your library from ~/Music at all to somewhere else?

    Have you tried just dragging the file onto the iTunes window?

    R
     
  7. magda71 thread starter macrumors newbie

    Joined:
    Dec 21, 2014
    #7
    Yep. Tried dragging.
    Nope, not moved the library.
    And yes, they do indeed play back just fine in quicktime! :(
     
  8. zulkiflim macrumors regular

    zulkiflim

    Joined:
    Jan 6, 2008
    Location:
    Singapore
    #8
    Faced the same problem.
    Unable to load any files into iTunes 11.

    The only solution reinstall iTunes.
    Downloaded from web site then install iTunes 12

    Now the weird thing is videos won't play if you press the play button.
    The only way to play is if you right click and click "Play "name of movies""
     

Share This Page