itunes won't import cd

Discussion in 'Mac Apps and Mac App Store' started by hieronymoose, Apr 9, 2007.

  1. hieronymoose macrumors newbie

    Joined:
    Apr 9, 2007
    #1
    I'm having trouble importing Audio CDs.

    The CDs never even mount on the desktop, let alone open in iTunes. After I put them in the computer, I can hear the drive making noise, spinning up, and spinning down, and after about thirty or forty seconds it spits the CD out again.

    This is happening with most of a large bunch of CDs that I recently received from a friend. Some of these cds are relatively new, while others are years old. Some of them are produced by major labels, others by smaller, independent labels. None are home-burned. This is the first time I've tried to import from a CD in months.

    I tried some of these CDs on my mother's iBook (1.something Ghz G4, 14") with the exact same results.

    We're both using the latest version of iTunes, and the latest version of OS X. I have repaired permissions and restarted both machines, with no change in behavior.
    :confused:
    Does anyone know what's going on?
     
  2. psychofreak Retired

    psychofreak

    Joined:
    May 16, 2006
    Location:
    London
  3. hieronymoose thread starter macrumors newbie

    Joined:
    Apr 9, 2007
    #3
    I have tried that. Again: this isn't just one CD, these are a set of several, random CDs, some of them almost brand new.

    Also: Upon further experimentation, I've found that many of them *will* import into my mother's iBook, but there's still a significant number of discs that won't mount on either machine.

    Anyone?
     

Share This Page