iTunes wont import my music. Access Privileges.

Discussion in 'Mac Apps and Mac App Store' started by wolverineandrew, May 15, 2013.

  1. wolverineandrew macrumors newbie

    Joined:
    Nov 11, 2009
    #1
    Ok so a few months ago i got a new imac so i transfered over my music library from a time machine back up from my macbook. It worked fine. Im getting rid of it now and i want to move back my itunes library from my iMac back up to my macbook pro. I did that and i went to import some music from my desk top and its giving me this error

    "Attempting to copy to the disk "my disk" failed. You do not have enough access privileges for this operation"

    I went and edited the access privileges in all the files in the music/itunes folder and it still wont import. Any ideas here? I also went to disk utility and repaired disk permissions and that didnt help.
     
  2. opinio macrumors 65816

    Joined:
    Mar 23, 2013
    #2
    Did you authorise the new Mac in iTunes?

    Also you can change the privileges in the folder by going to 'Info' on the top folder (iTunes?) and adding your user name in the list at the bottom of the info window. Alternately click "cmd i" when you have the iTunes folder clicked. Choose 'read and write' on your new added user and 'apply to enclosed items.' Also you will need to inclock all that too by clicking on the padlock icon at the bottom.
     
  3. swankster macrumors newbie

    Joined:
    Sep 8, 2010
    #3
    I had the same problem.

    I changed the permissions of my Library\iTunes folder.

    Make sure the permissions show your admin user name and "read/write"
     
  4. tomcxp macrumors newbie

    Joined:
    Jun 6, 2010
    #4
    This worked for me! The trick is to update the top level folder where media are located: once you've found the folder utilize Get Info, click the Lock to enter your password, set the access to read/write, and choose "Apply to enclosed items" from the cog. For a visual walkthrough of this check out:
    http://www.mactricksandtips.com/2008/03/automatically-set-subfolders.html
     

Share This Page