iTunes won't locate source folder

Cavara34

macrumors member
Original poster
Aug 14, 2012
83
2
I've moved my iTunes library to another drive and I've linked to it through preferences and by holding "option" down at start up. Everything now appears - the media, artwork, playlists, etc., it just doesn't play. It does continue to play when linked to the previous disk.

Locating one track and then selecting the option for iTunes to try to locate the others didn't affect anything.

Any help is appreciated.
 

Cavara34

macrumors member
Original poster
Aug 14, 2012
83
2
Thanks for replying.

I moved the iTunes media folder, along with album art and other related files.

They were originally on external drive which I needed to reformat, so I moved them to a different external drive, redirected iTunes and got it working. Having now reformated the drive, I moved it back and it reproduces everything except that it won't play anything.
 

Cavara34

macrumors member
Original poster
Aug 14, 2012
83
2
Are there possibly any issues with the drive you just formatted? (Just thinking of all possible scenarios.)
Couldn't be that. I can manually locate tracks in the folder and play them; I just can't do that for thousands of tracks.
 
Last edited:

Cavara34

macrumors member
Original poster
Aug 14, 2012
83
2
Thanks, I may try that. Can you explain "links"?

My other thought was to delete iTunes media from the target disk and transfer it again, only this time instead of dragging it and then redirecting, I'd redirect first and ask iTunes to consolidate in that folder? Then it will transfer everything itself? Is that possible?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.