iTunes won't recognize external drive

Discussion in 'Mac Apps and Mac App Store' started by kristeva, Sep 29, 2016.

  1. kristeva macrumors newbie

    kristeva

    Joined:
    Apr 22, 2016
    #1
    Hi all,

    I've always stored my music on an external HD (and ignored the iTunes folder on my Mac main drive). I set it up years ago during my 'PowerPC/OS 10.5' days and forgot about it. After seeking some advice here, I recently upgraded to a powermac 4.1/OS 10.10 and used Time Machine to transfer my files. Everything was fine including iTunes.

    Last night I had a mad moment - I decided to change the name of the external HD where I store my music and of course quickly realised my error when I fired up iTunes - it couldn't locate any of my files, and I couldn't remember the old name of my HD (Disk1, or something generic like that)!

    I've tried iTunes/preferences/advanced - and then alter the iTunes media folder location, but that doesn't seem to be the answer. And I tried pressing the Option key on start up to identify my external HD but iTunes says - "iTunes library folder can't be located on this drive....."

    iTunes on 10.10 is obviously a little different to what I had before during my 10.5 days - is there something I'm missing? or am I going to have to transfer my iTunes folder from my main drive into my external hard drive and put all my music files into that?

    Thanks.
     
  2. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    You could try trashing the iTunes preference files, and try again.

    More thoughts:
    Is the external drive still showing up in the Finder?
    What is its formatting/partitioning scheme (you can check with Disk Utility)?
    What is a "powermac 4.1" …?
     
  3. Partron22 macrumors 68000

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #3
    Yosemite.
    Did you open up the new version of iTunes and let it update your library before changing HD name?
    It may be having trouble with the combo of new disk name and out of date library structure.
    I ran Yosemite with iTunes lib on an external drive with no problems.
    What format is the drive in? GUID? iTunes might care about that.
    A temporary library move, a reformat to modern Mac std, and move library back might fix your problem.
     

Share This Page