I've broken my iMac! Help needed

Discussion in 'iMac' started by Shutt81, Sep 23, 2014.

  1. Shutt81 macrumors newbie

    Joined:
    Sep 23, 2014
    #1
    I was given an old iMac from my work and i wanted to do a complete re-install of everything.
    Ended up following a YouTube clip to delete everything and I ended up erasing the Macintosh HD in Recovery mode and now im forever stuck in MAC OS X UTILITIES.
    It wont let me reinstall Lion from the option, as it gets to the Apple ID login then gives an error.
    Iv also tried booting from USB and also from a Boot CD but on this is says the installation cannot be completed.
    The system was working fine until I started this failed mission!

    Couple of other things:
    HD is verified and is ok, so I don't think any problem there.
    Macintosh HD doesn't appear in Start up disk, only the Boot CD (but has the failed problem listed above).

    Help is needed please! Im stuck for ideas.
    Thanks.
     
  2. Dopeyman macrumors 6502a

    Joined:
    Sep 5, 2005
    Location:
    Los Angeles!
    #2
    Did you try formatting the hard drive before re-installing Lion?
     
  3. Shutt81 thread starter macrumors newbie

    Joined:
    Sep 23, 2014
    #3
    I did do that at the start, but im trying again now to see if it makes any difference.

    Also a little while ago I did manage to get Lion to start reinstalling and then I got "Can’t download the additional components needed to install Mac OS X" so I was back at the Mac OS X Utilities menu again.
     
  4. Mugwumper macrumors regular

    Joined:
    Jan 19, 2008
    Location:
    Palmdale, CA
    #4
    What kind of iMac is it?

    Can you tell us what kind of iMac it is? Any details about CPU, RAM, HD size, screen size, CD or DVD drive, etc. This may be a clue as to what the latest version of Mac OS will be able to run on it.

    Also, any idea what OS was running on it before you started this?

    My memory is fading, but it may be that you have to go back to a Leopard boot CD and start over. Then, when that works, upgrade to Lion.
     
  5. Shutt81 thread starter macrumors newbie

    Joined:
    Sep 23, 2014
    #5
    its a 22inch (i think) iMac 2009 - 4gb ram - 640gb HD. Its got a Superdrive.
    It was running Lion before I managed to mess everything up.
     
  6. Mugwumper macrumors regular

    Joined:
    Jan 19, 2008
    Location:
    Palmdale, CA
    #6
    Probably need Snow Leopard

    This is probably a 21.5in display, and the internal HD was either 500GB or 1TB. So if you have 640GB, maybe it was a special build, or somebody replaced a failing 500GB with a 640GB. This should have a 3.06GHz or 3.33GHz Core 2 Duo CPU.

    Snow Leopard was delivered with this model ("late 2009"), so I'd suggest you use the original boot CD or DVD, and just do a clean install from scratch (erase the disk before the install). If you don't have the Snow Leopard disks, looks like you can buy it here:

    http://store.apple.com/us/product/MC573Z/A/mac-os-x-106-snow-leopard

    Anybody else have any ideas?
     

Share This Page