I've tried everything...

Discussion in 'Mac Basics and Help' started by Elcid!, Feb 13, 2008.

  1. Elcid! macrumors newbie

    Joined:
    Feb 13, 2008
    #1
    I've got a dvd stuck in my wretched powerbook g4. I've tried pressing the mouse button, f12, and the eject button during startup. I also did that thing where you type in "eject cd" nothing happened. I'm living in Italy and I tried to take it to this "mac" store and they couldn't do anything either. Damn. Suggestions, please. Please?
     
  2. atszyman macrumors 68020

    atszyman

    Joined:
    Sep 16, 2003
    Location:
    The Dallas 'burbs
    #2
    Have you tried Disk Utility? I think I've been able to make it eject non-recognized disks for me in the past...
     
  3. Kalafut macrumors regular

    Kalafut

    Joined:
    Jan 6, 2008
    Location:
    pocatello
    #3
    you can always try and take out the entire cd drive then remove the cd like afterward, google for instructions.
     
  4. kuwisdelu macrumors 65816

    Joined:
    Jan 13, 2008
    #4
    I believe there's an "eject DVD" lever hidden inside the slot-loading drive. It may be scary, but if you stick a paperclip or something in there, you might be able to hit that and eject it. Google this before trying though...
     

Share This Page