iWeb '08: The document "Domain.Sites2" could not be opened

Discussion in 'Mac Apps and Mac App Store' started by RodySt, Aug 21, 2007.

  1. RodySt macrumors newbie

    Joined:
    Aug 21, 2007
    #1
    I'm having a major problem with iWeb '08.

    I upgraded to iWeb '08 last week, and it has been working OK since then.

    My '06 sites were transfered to '08 sites - everything ok.

    Until last night, when I tried to open iWeb '08 again...
    I got these error messages (attached)

    What I tried to fix it (but didn't work):
    copied old domain.sites2 file to another folder
    restarted iWeb and created a new site.
    iWeb worked fine with a new site.

    When I replaced the package contents of the new domain.sites2 with the old and restarted iWeb - still the same error.

    Basically I lost all of my website (including one business)

    I really need to get it working again - otherwise it will costs me days to start over again...

    Please help!
     

    Attached Files:

  2. CaroleLeigh macrumors newbie

    Joined:
    Nov 14, 2007
    #2
    the document "domain" could not be opened...

    I am having the same problem with the "domain" not opening but I am on 06. Have you figured out how to fix it. I have several websites up and at weeks worth of work down the drain.
    I've tried (none of these worked):
    Updating the software...
    Re-installing the program...
    Removing "domain" from Application support and launching it from another folder...
    Removing it completely and relaunching iWeb (which only brings me a new page but I still can't retrieve my site)...
    Dropping and dragging the site into a clean iWeb...

    I have checked and all the files with for the sites still exist in the Domain folder.
    Please, if someone has figured out how to fix this...I'm bordering on desperate.
     
  3. thornstrom macrumors newbie

    Joined:
    Jan 9, 2008
    #3
    domain.sites2

    I have exactly the same problem and no solution yet. Will get back here when I have one.

    PT
     
  4. mattejacob macrumors newbie

    Joined:
    May 7, 2007
    #4
    solution

    navigate to your home folder Library/Prefrences/com.apple.iweb.plist
    open it with textedit or property list editor if your running leopard, scroll to the bottom of the file or look for the string lines in property list editor and you'll see <string> and then the file that caused the crash, delete the whole line <string> and all, save and you'll be in business. hope this helps.
     
  5. NSToffee macrumors newbie

    Joined:
    Feb 23, 2008
    #5
    domain.sites2

    Hi - thanks for offering the solution.

    Unfortunately, I do not seem to have that plist under that folder or anywhere. There is one for iLife'08 but nothing in there relating to iWeb (when opened in TextEdit).

    If anyone else has any thoughts, they'd be much appreciated. Thankyou.
     
  6. Mitou macrumors regular

    Joined:
    Jan 25, 2008
    #6
    First my suggestion would be to make a copy of that domain file rename it something else and move it where you will be able to get it again. You do not have to move it back to the original folder to open it, and it does not have to be named domain. Just double clicking on any x.sites2 file will open it in iweb. so secure that file.
    Second you must have a plist if you can open a new site, iweb has a preference file.
    check under
    Home Folder/Library/Preferences/com.apple.iWeb.plist.
    Make sure iweb is off before doing anything to it.
    I cannot speak for the step outlined above. I would just trash the file. relaunch and try opening the file by double clicking.
    Good luck
     

Share This Page