iWeb 09 and Subfolders

Discussion in 'Web Design and Development' started by Cave Man, Jun 20, 2009.

  1. Cave Man macrumors 604

    Cave Man

    #1
    Is there a way to disable the generation of the subfolder that iWeb publishes to by ftp to a remote server? I have a URL, http://www.zyzy.org/ but when I publish, iWeb insists on having those items put into a folder on the site that matches the "Site Name" in the iWeb site pub window (i.e. the iWeb site name is "zyzy" and iWeb wants to publish in [http://www.zyzy.org/). I leave "Directory/Path" blank in iWeb.
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    You can take just the contents of folder xyz and upload that, so the xyz folder itself wouldn't get uploaded. I believe that would resolve the issue. If not, you may need to clarify.
     
  3. Cave Man thread starter macrumors 604

    Cave Man

    #3
  4. Cave Man thread starter macrumors 604

    Cave Man

  5. eclipse macrumors 6502a

    eclipse

    Joined:
    Nov 18, 2005
    Location:
    Sydney
    #5
    I've just sent this as a feature request to iWeb. It currently CANNOT load straight into the public_html folder.

    it ALWAYS creates a folder with the same name as your site name that will sit under your server's root folder.

    So what I do to prevent having my website go from example.com to example.com/example in the URL, I publish to a local folder and then drag the contents using CyberDuck (free).

    Or, you could try calling your site public_html and see if that works at "tricking" the root into accepting that the iWeb directory site folder name (now called public_html) over rights the root folder on the server, so that your site sits in the root. I know it's a terrible name sitting on your iweb folder, but no one else will see it if it works.

    Other than that, I've written to Mac about it and we'll see what 2010 brings.
     

Share This Page