iWeb communication with FTP server error

Discussion in 'Web Design and Development' started by maspalmeras, Jan 2, 2010.

  1. maspalmeras macrumors newbie

    Joined:
    Jan 2, 2010
    #1
    I am trying to publish from iWeb to an FTP server. I have done this before with no problem. But using all the same settings, to update the site and replace pages, I keep getting the message,

    PUBLISH ERROR
    There was an error communicating with the FTP server try again later, or check with your service provider.

    I have tried later for a week, with no luck.
    I have checked with the service provider who confirms all is ok.
    I have checked all the settings. The blank field is path, but I never filled this in the past and filling it now just brings up the message, path not recognised.
    When I test the connection in iWeb (With path left blank) it confirms I can publish.
    When I publish, it prepares the files and tells me publishing will continue in the background. Then after a while the message appears. It feels as if it is getting stuck.

    Anyone got any thoughts.
     
  2. adamvk macrumors 65816

    adamvk

    Joined:
    Oct 29, 2008
    Location:
    Phoenix, AZ
    #2
    iWeb is quite buggy. If there is a problem with your internet connection when you first open iWeb, it won't upload. Just restart the program, and that should fix it.
     
  3. Dingy macrumors newbie

    Joined:
    Feb 18, 2010
    #3
    I'm getting the same error message and nothing is working. I can upload my other, smaller, website just fine. Do you think this has something to do with the size of the website?

    Maybe it's timing out?

    Anyway to fix this?

    Thanks.
     
  4. illegalprelude macrumors 68000

    illegalprelude

    Joined:
    Mar 10, 2005
    Location:
    Los Angeles, California
    #4
    It might be a size issue for some reason because I have a smaller iWeb website with the same FTP settings (of course different root folder) and it works no problem but my much larger site is a no go with iWeb and using the same FTP settings....guh
     
  5. daledye macrumors newbie

    Joined:
    Apr 12, 2011
    #5
    My fix was simple

    I've been having this issue for some time on my Podcast. I completely tor apart my page, trashed my old podcast and started a completely new on and still it would not post. Started having the same problem on a very simple page after I added a new photo.

    Finally figured out my problem. The jpeg I was using as the image for my podcast and the jpeg on my new page both had a space as the first character in the name of the file.

    So apparently if the file name stars with a space [which was completely accidental in both cases] it will freak out iWeb. My stuff always posted to the FTP but my iWeb program always gave me the error.

    Hope this helps someone else.
     
  6. mikek947 macrumors newbie

    Joined:
    Oct 24, 2011
    #6
    I believe I know what the problem is. When I uploaded using Transmit 4 to upload my site files I got errors that the site did not like the name of the file. All files must basically be one word, no spaces and only contain letters and number, under stroke or dash. Any other characters cause the problem. I changes all the file names and it uploaded everything with no error. So any picture or file used in iWeb must be one word and no special characters. Try it and see if this helps.
     
  7. polarlow macrumors newbie

    Joined:
    Nov 26, 2011
    #7
    Space at start of file name

    Thanks for pointing out that you can't have a space at the start of image file names when using iWeb. I don't think I'd have ever worked that one out on my own!
     
  8. tom91221 macrumors newbie

    Joined:
    Dec 23, 2011
    #8
    Filezilla Download


    I read your problem which is something same like I've got before. I also get very tensed when nothing was happening. Then, someone have suggest me about the filezilla ftp server. I've implement this software for uploading my files over network. It is really a great one, because firstly free of cost and is very simple to use. I hope this might be the ftp server you are waiting for. For more information on it you should opt to filezilla download user guide.
    Thanks.
     
  9. iRezaa macrumors newbie

    Joined:
    Feb 10, 2012
    #9
    Definitely helped me, thanks a million :D
     
  10. thefoolangel macrumors newbie

    Joined:
    Feb 21, 2008
    #10
    Same problem, but can't see the solution

    I have the same error message and like the OP I have changed no settings and can upload to my other sites with no problem. The test connection works fine but stillI get this error.

    In my case I simply removed a html snippet and a text box from the page I no longer wanted, moved the things below it up to fill the gap - and I ran into the problem.

    So nothing has been added, and only two things removed - what can I search for that could be causing this?

    Any ideas appreciated!
     

Share This Page