iWeb Domain file

Discussion in 'Web Design and Development' started by iJED DV, Aug 2, 2007.

  1. iJED DV macrumors member

    iJED DV

    Joined:
    Jun 21, 2006
    #1
    I just got a new MBP. I have website built in iWeb on another computer. I copied the domain file from my old computer to my new one and was able to access all my pages. I made changes, saved them and published them. However, if I turn off or restart my MBP and launch iWeb, the domain file does not contain any of the changes I've made. I have tried this a couple of times. Any ideas?
     
  2. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #2
    That is puzzling. Are you sure you are replacing the file when iWeb is closed.
     
  3. iJED DV thread starter macrumors member

    iJED DV

    Joined:
    Jun 21, 2006
    #3
    I will try it again to double-check, but I believe I'm replacing it while iWeb is closed.
     
  4. steevun macrumors newbie

    Joined:
    Apr 7, 2008
    #4
    Any solutions to the "iWeb won't save to domain file" problem?

    I am having the same problem on iWeb. I make the changes and then save and publish. All seems fine, then I reopen the domain file and the changes are not there...help.
     
  5. Mitou macrumors regular

    Joined:
    Jan 25, 2008
    #5
    have you tried deleting the preferences file and reopen iWeb by double clicking
    the domain file. then close iweb but not the computer and reopen iWeb if the file is okay then the problem is not an iWeb problem but a system problem.
    Make sure you make a copy of the file before doing anything.
    :)
     
  6. steevun macrumors newbie

    Joined:
    Apr 7, 2008
    #6
    Fix to the iWeb doesn't save...

    All:

    After countless hours of fiddling around the solution was rather simple. If you are using iWeb on multiple user accounts and have pointed the program to the domain file on another user, iWeb may default ANOTHER domain file within your own account.

    This explains why changes were being made to one domain file (my own) and yet when I open the program it was opening the domain file on the other user - thus the changes were not there.

    The simple solution was to move the domain file you want to the Shared folder on the machine. Delete all other domain files including the iWeb folder that holds them. Then open the shared domain file in each user which "points" the program to that file and viola - the changes appear.

    Hope this helps someone.
     

Share This Page