Iweb help strange symbols

Discussion in 'Web Design and Development' started by stourm, Mar 6, 2008.

  1. stourm macrumors newbie

    Joined:
    Mar 6, 2008
    #1
    I have I have installed iLife 08 and just started using iWeb to create some web pages. There is something odd occurring though when I use apostrophes and spaces in some areas. I can't figure out what it is doing, or why and have tried changing fonts, size, etc. It does this no matter what browser I am using (IE, Firefox, Safari.) I will post some samples below...any help would be greatly appreciated.

    Welcome To Luke’s Page (Should be: Welcome To Luke's Page)
    Time:Â Â Â Â Â Â Â 7:42 AM (Should be spaces after the colon)
    If i were an animal, I’d be a (Should be: If I were an animal, I'd be a)

    I am using apostrophes and spaces other areas with no problems. If anyone has any ideas what might be causing it please let me know. Thanks in advance.

    Alan
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    The short answer is that it's an text encoding issue. I don't use iWeb some can't help much further. What may help others here to help you is to know what is the primary language on your Mac set to, and if you have any other languages enabled.

    As an example of the encodings, when I change my browser's encoding (in Firefox > View > Character Encoding) to UTF-8, the apostrophe's in the message you left are shown and those A type characters become question marks. The question marks generally mean the given character isn't defined in the character set.
     
  3. stourm thread starter macrumors newbie

    Joined:
    Mar 6, 2008
    #3
    encoding

    I am using only english and I have not enabled any other languages on this Mac. As a matter of fact, this is pretty much a fresh load (4 days ago, clean install) of Leopard and iLife 08. I haven't really installed a lot of other applications so I don't know what could have caused it.
     
  4. masterme macrumors newbie

    masterme

    Joined:
    Jul 18, 2007
    #4
    Iweb makes the fonts in unicode, which is default in firefox

    Change the view of safari to Unicode UTF-8

    Just goto safari/preferences/default encoding,
    and put this on Unicode (UTF-8) then you see the site normally.
    To make this every viewers default code:

    Make a folder called .htaccess
    This is just an ordinary plain text file named .htaccess with the text "AddDefaultCharset UTF-8" and put this in the top most directory on the server you host you site.

    that should do the trick.

    this link might help
    http://homepage.mac.com/thgewecke/iwebchars.html

    cheers,

    Moreeazy
     
  5. wabes2k macrumors newbie

    Joined:
    Sep 8, 2008
    #5
    I tried this out and I'm still having the same problem. I also tried unchecking "Use Smart Quotes" in iWeb's preferences. Any other ideas?

     
  6. SrWebDeveloper macrumors 68000

    SrWebDeveloper

    Joined:
    Dec 7, 2007
    Location:
    Alexandria, VA, USA
    #6
    The advice about the .htaccess is for Apache web servers only, so if your web server isn't that, don't follow that advice.

    Do not adjust the browser, it should default to match the web site - the encoding information is included in the top of the source code for your site if iWeb is doing its job properly. The browser will adapt with its default settings for encoding.

    One thing I am guessing is you are copying from a document or file and pasting into iWeb. Is this true? If so, the clipboard used for copy/paste might be inserting characters unique to the document or file and not supported in the character set iWeb is using. UTF-8 is one such character set, but it's a web standard, NOT a document standard, and one of many. As noted earlier, the odd characters are unsupported in the character set used by iWeb.

    So the simple solution is open up Notepad or a standard text editor in text mode, paste into that first (which strips all non-supported characters) and then copy/paste from the text editor into iWeb. Do not use rich text, use good old fashioned ASCII.

    If this is not what you're doing, we need the link to your web site so we can see what encoding and DOC type you're using for better advice.

    -jim
     

Share This Page