iWeb Hyperlinks Don't Hyperlink

Discussion in 'Mac Apps and Mac App Store' started by Tallest Skil, Mar 3, 2008.

  1. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #1
    Okay, so I'm setting up my website and it's quite a bit like the Apple site. I set up links to my other pages from each page, but when I check "activate hyperlinks" and then click one, I always go back to the main page (The Psywave Corporation). What am I doing wrong, if anything, formatting-wise? How can I fix this?

    Thanks.

    Sorry, here's an image of my setup.
     
  2. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #2
    The default, I believe, is to link to the home see pic

    Picture 1.png Picture 2.png

    Change the page you want it linked to.
     
  3. Tallest Skil thread starter macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #3
    I did. I did for each page on each link to its respective page. It always takes me home.
     
  4. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #4
    Have you tried publishing it to check?

    You could always use the option External page and type the url in there by yourself.
     
  5. Tallest Skil thread starter macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #5
    ...no... I don't exactly have .Mac. It's just for our Entrepreneurship class, but I wanted it to flaunt Apple-designed style like nobody's business. I'd just like the hyperlinks to work even within iWeb so that I could present it.

    There aren't any free hosting services, are there? :eek::p
     
  6. Pees330 macrumors 6502

    Joined:
    May 26, 2006
    Location:
    Las Vegas, NV
    #6
    You could always just publish to a folder and fire it up from there to check it out. The option is under the File drop down menu.
     
  7. Tallest Skil thread starter macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #7
    Cool... Okay, tried it; didn't work. And it cuts off the title on my home page! It moves it over and blocks some of the words!

    Tanj in torment.
     
  8. xUKHCx Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #8
    I didn't think links worked inside iWeb

    What I was sort of hinting at before. Just publish to a folder say the Desktop and it will put an index.html file and a folder. Just double click the index.html file and your website will popup in your favourite browser (much snappier than on the actual internet)
     
  9. Tallest Skil thread starter macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #9
    Okay, I started the timer on my .Mac to try to publish to see what would happen.

    It still won't link past my first page and my title is still unformatted.

    What should I do?! Here's my page.

    As you can see, it looks like the Apple site. Click on C. and it takes you to the first page, but no further. When you click any of the other tabs it takes you home. I've set each tab on each page to go to its respective page. It doesn't work. What do I do?

    Thanks.
     
  10. DatanBasen macrumors newbie

    Joined:
    Sep 29, 2010
    #10
    Me Too

    I'm having the exact same problem!

    The links I made at the top of my layout work, the ones at the bottom do not. They ALL take me to the home page.

    Twitchy program. Can anyone tell me how twitchy iWeb pages are on various browsers--am I headed for a nightmare???

    Datan
     

Share This Page