iWeb site misbehaving in Firefox

Discussion in 'Web Design and Development' started by sk3pt1c, Sep 15, 2009.

  1. sk3pt1c macrumors 6502a

    sk3pt1c

    Joined:
    Nov 29, 2005
    Location:
    a simulacrum
    #1
    any idea why Firefox is placing the shadows differently than IE and Safari on this site?
    there's basically no content in it, just dummy pages and the navigation...
    thanks
     
  2. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #2
    I can't help but wonder if it's caused by the undefined image map on the active button. That's throwing an error with the validator.
     
  3. sk3pt1c thread starter macrumors 6502a

    sk3pt1c

    Joined:
    Nov 29, 2005
    Location:
    a simulacrum
    #3
    i haven't touched the code at all, it's auto generated from iweb...
    looks ok on safari (well, it would) and IE but Firefox is placing the boxes
    around the icons and text...
    i checked that error, says tags aren't closed properly and whatnot, but i don't see anything out of order...
    it's the same as in the other icons, i don't see why pop an error up there...
    i see though that if you try another page the same error appears but on a different map... hmm...
     
  4. sk3pt1c thread starter macrumors 6502a

    sk3pt1c

    Joined:
    Nov 29, 2005
    Location:
    a simulacrum
    #4
    turns out it may be an issue with the rendering of shadows for the PNGs
     
  5. johnnyjibbs macrumors 68030

    johnnyjibbs

    Joined:
    Sep 18, 2003
    Location:
    London, UK
    #5
    I've started getting this on my site too (http://www.johngriffithsapps.com/). It works fine in Safari and Chrome but Firefox is a problem.

    I'm just using standard shapes with shadows in iWeb. Any idea of how to fix?
     
  6. sk3pt1c thread starter macrumors 6502a

    sk3pt1c

    Joined:
    Nov 29, 2005
    Location:
    a simulacrum
    #6
    looks like an issue with the png files and shading... no idea mate :)
     
  7. johnnyjibbs macrumors 68030

    johnnyjibbs

    Joined:
    Sep 18, 2003
    Location:
    London, UK
    #7
    Cheers - never mind, will have to change the design.

    Don't remember this occuring before so must be a newish compatibility issue from a recent Firefox update. I'd like to ditch iWeb to be honest but don't really have the time or inclanation to learn HTML!
     

Share This Page