iWeb Wont Save!

Discussion in 'Mac Basics and Help' started by Sweener88, Jan 29, 2007.

  1. Sweener88 macrumors 6502


    Apr 27, 2006
    Hi after a many hours of working on my site i got this error!
    "The document "iWeb" could not be saved"! Any ideas on what to do?! thanks for the help!!! :confused: :eek: :( :apple:
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Is there any more to the error message? What other apps are open?
  3. bbergie macrumors regular


    Jul 3, 2006
    Are you saving your work to a folder or to the .Mac server? If the latter, and you're saving your work and publishing simulaneously, try going up to "file" and then strike "publish all." That's gotten me out of a jam before. Alternatively, have you tried just hitting "file" then "save" (rather than publish) on its own?
  4. riel505 macrumors member


    Feb 8, 2006
    hi! would also appreciate help on this line... ive used iweb several times before but never had a problem with it except yesterday, it kept telling me 'iweb cannot save'. i've been tinkering with my site's new design and now i can't save! i've tried 'apple s' and going to file, save. i've also tried to publish directly to a folder but it prompts me to save first then the message comes on again 'cannot save'. i've been keeping my mac open or on sleep because i don't want to redo the design again.. :( there are no other aps open aside from iweb.
  5. ervdoggie macrumors newbie


    Sep 27, 2007
    iweb cannot save---- FIX !!!

    I'll try to keep this short on what I did to fix the problem for me. I had to put on my Windows troubleshooting hat of 12 years :eek: to get back into the logic of troubleshooting. A bit of a challenge as a new Intel MacBook user with a new GUI when you can't get under the covers very easily and make it do what you want, which is nice for change. I still work in Windows which is enough of a challenge on its own. Mac is just new for me and it's fun. Okay, on to the fix.

    I'm using iPhoto v 6.0.6 (322) and iWeb v 1.1.2

    I too experienced this problem while working with iWeb. As always, you want to have your media and photos already organized and "named" in iPhoto. I publish from iPhoto to iWeb and use the Media Manager button in iWeb to drag photos and movies etc. onto the appropriate web page and edit/arrange them there.

    Here is the catcher. DO NOT MOVE RENAME OR DELETE any of the media you are working with in iPhoto that is utilized in iWeb. If you do, it "breaks the link" that iWeb connects to the name/location of the media in iPhoto or wherever the data used is being stored.

    When I worked on my site that was perfectly fine and tried to save I got the error. Multi-tasking as we often do with computers I realized what I did while renaming/organizing photos and simultaneously publishing them in iWeb. Somewhere in that mix I got out of sync and changed something AFTER I published in iWeb and that is when it would not save. I realized that changing any of these in iPhoto (or wherever for that matter) "AFTER" you share to iWeb will cause iWeb not to save because it can't validate the location/name of the media that was used. This is just my theory of what I think is going on under the covers with the software based on how I fixed the problem. :D

    Hope that helps!
  6. bennettfarkas macrumors newbie

    May 27, 2009
    here you go...

    if you have been moving files around, and your domain file is in your application support file, go to that domain file, get info on it (command i) and check the permissions. if you moved this file from a backup, the file will be locked so that it is for reading only. click the lock on the bottom right, and authenticate it... then change it to read and write.

    you should now be able to save... if this was the issue.

    hope that helps.
  7. TheChazJaz macrumors newbie

    Jan 1, 2010
    Fontana, CA
    This worked for me1

    I had to do a clean reinstall of all of my Apple products due to attempts at migrating from Leopard to Snw leopard (and from two other older OS's). All sorts of madness was going on. I went and bought a 2TB Western Digital Barracuda drive, installed it and have been doing a clean reinstall of all of my software.

    Moving the 'domain' media from the old drive to the new drive 'broke the link' to all of my images. It was a simple matter of doing as 'ervdoggie' suggested and changing the permissions on the media.

    Thanks guys!


Share This Page