iWork and spelling dictionaries

Discussion in 'Mac Apps and Mac App Store' started by northernmunky, Sep 14, 2007.

  1. northernmunky macrumors 6502a

    northernmunky

    Joined:
    Jan 19, 2007
    Location:
    London, Taipei
    #1
    Just started using Pages for Word Processing, so far I am more impressed with it than I thought and have started using it more than NeoOffice but one gripe is the spellchecker. I can't find any way to change the dictionary from 'American English' to well.. 'English English'!

    I've changed every possible OS setting I can find to UK English but it still claiming that words like 'colour' is spelled wrong!??? Arrrrgh :mad:

    Anyone know how to switch this over? :confused:
     
  2. kiwi-in-uk macrumors 6502a

    Joined:
    Sep 22, 2004
    Location:
    AU
    #2
    Try Inspector>Text>Other>Language>"Pommy English"
     
  3. northernmunky thread starter macrumors 6502a

    northernmunky

    Joined:
    Jan 19, 2007
    Location:
    London, Taipei
    #3
    Haahaa... Found it, it was in Inspector > Text Inspector > More > Language
    on mine! Hey I've got no problem with Aussie English, but I thought even you guys would prefer 'Aussie English' over the forced down your throat until you cant bloody breathe 'Yankee English'! :p

    If you look in the international language preferences for MacOS you'll notice American English is simply referred to as 'English' next to 'British English', 'Australian English' and every other nations version of English......
     
  4. freshj macrumors newbie

    freshj

    Joined:
    Oct 25, 2007
    #4
    Hey guys do you know how to set British English as the default language so you don't have to set it every time you start a new document?
     
  5. freshj macrumors newbie

    freshj

    Joined:
    Oct 25, 2007
    #5
    I just found an answer to my own question:

    Open System Preferences>International>Language>Edit List>Check British English>Click OK>Drag British English to the top of the Languages list.

    Now all programs will set British English as their default dictionary (handy for iWork and Adium spell check)!
    :cool:
     
  6. applelady macrumors newbie

    Joined:
    Feb 21, 2008
    #6
    After all this time!

    Thanks freshj - this has been bugging me for ages!
     
  7. badgerawai macrumors newbie

    Joined:
    Jul 28, 2009
    #7
    I only have ENGLISH no other english to choose from :(

    Does anyone know why this is? I'm desperate to get English UK on my iworks pages...
     
  8. PeggyD macrumors 6502a

    Joined:
    Jan 9, 2007
    Location:
    Covington, WA, USA
    #8
    You need to add British English to the list in System Preferences > International. If you can't add it, you may not have it installed (although it should be if you chose English as the system language when setting up your Mac). You may have to reinstall the system.
     

    Attached Files:

  9. Ranza macrumors newbie

    Joined:
    May 2, 2008
    Location:
    Sydney, Australia
    #9
    Finally iWork defaults to Australian English, thanks for pointing it out, I didn't set it up write in System Preferences:)
     
  10. aktizol macrumors newbie

    Joined:
    Oct 5, 2011
    #10
    I have only recently bought a Macbook Air and using the Pages application. I found it perfect for my academic writings. It is indeed very light and responsive compared to the MS Word. I had trouble with the dictionaries, as I couldn't find the way to change the dictionary language.

    Thank you for the tip. It worked for me. :D
     
  11. biallystock macrumors member

    Joined:
    Jun 2, 2009
    #11
    The Australian Dictionary is a fraud, and a sop to Australian users. It is just the British dictionary. It won't even recognise anzac, Melbournian, goanna, lamington and vegemite.

    The only reason it appears to recognise ANZAC or Anzac is that it ignores acronyms or capitalised subjects.
     

Share This Page