iWork not accessing iCloud docs

Discussion in 'Mac Apps and Mac App Store' started by Achiever, Apr 17, 2014.

  1. Achiever macrumors 6502

    Achiever

    Joined:
    Jan 23, 2008
    #1
    I am running the newest versions of all three iWork apps on my iMac and MBA. On the MBA, they run flawlessly and when opening any of the apps I am given the option to open documents from my Mac or from iCloud. When I choose the iCloud options, I find all iCloud saved documents, properly synced.

    On my iMac, however (2009 27" iMac with regular HD, FWIW) opening any of the apps brings me to the usual open/save dialogue box which allows me to navigate my Mac to open a document, however when I click on the iCloud button it instead treats the option as though I were digging into the Mac HD instead of bringing me to iCloud. So for example, if the Mac side had me clicked into my Documents folder, when I click iCloud, the left most column (in column view) is the Documents folder. It doesn't show the cloud, any of the documents saved in iCloud or even let me navigate backwards (such as from Documents to my home directory in the above example).

    I haven't yet tried deleting the apps and reinstalling them as I have had trouble installing them in the past. Specifically, there had been updates available for months and the App store refused to find them or listed the updates as having been installed despite me having an older version. I have logged out of iCloud on this machine and logged back in. Still no go. This is happening on all three iWork apps.

    Thoughts or suggestions? Thanks in advance.
     
  2. Achiever thread starter macrumors 6502

    Achiever

    Joined:
    Jan 23, 2008
    #2
    Since posting I have deleted the apps and reinstalled them. Same problem. I have no idea why it keeps happening on this machine, but it does. Still seeking thoughts.
     
  3. MLinneer macrumors regular

    MLinneer

    Joined:
    Mar 18, 2013
    Location:
    Sherman, TX
    #3
    Are you running Mavericks or Mtn Lion on the iMac? I had similar problems with iCloud items (calendars and contacts mostly) not syncing between my MBA running 10.9 and my iMac running 10.8. I could resolve it on the iMac by turning off the iCloud account, then turning it back on. That seemed to force a resync of all data.
     
  4. ricosuave macrumors 6502

    ricosuave

    Joined:
    Mar 27, 2007
    Location:
    In front of my mac
    #4
    Have you checked settings icloud documents in the cloud?
     
  5. Achiever thread starter macrumors 6502

    Achiever

    Joined:
    Jan 23, 2008
    #5
    Mavericks on both. I logged out of it completely but am having the same issue afterwards.

    Yes, documents are selected. I even unselected and reselected. No go.
     
  6. Achiever thread starter macrumors 6502

    Achiever

    Joined:
    Jan 23, 2008
    #6
    For what it is worth, while this did not work for me, it apparently has for others experiencing similar problems, so I thought I would share:

    Reset the Ubiquity folder on your problematic Mac(s):
    1. Quit open applications
    2. Go to Finder
    3. Choose “Go to Folder…” from the “Go” menu
    4. Enter ~/Library/Application Support
    5. Look for a folder named “Ubiquity”
    6. Move this folder to the Trash
    7. Restart your Mac
     

Share This Page