iWork not working after using Migration Assistant

Discussion in 'Mac Apps and Mac App Store' started by User12, Oct 8, 2012.

  1. User12 macrumors newbie

    Joined:
    Oct 8, 2012
    #1
    Hi,

    I just used migration assistant to move my files from my old HD to my new one. I am running OSX 10.6.8 and iWork '09 on my MBP - Mid 2009 (5,5). It now gives me an error when I try to open Pages, Numbers, or Keynote. It says there was a problem opening the app and that it may not be compatible with this version of the OSX? It is the same Snow Leopard and iWork since I bought the computer. It was working just yesterday prior to the migration.

    I have deleted the plist and also re-installed iWork from the original DVD. I also tried to launch iWork directly from the Applications folder instead of the dock. None of these have worked. Any suggestions?
     
  2. DoctorCrap macrumors regular

    DoctorCrap

    Joined:
    Oct 6, 2012
    Location:
    Penang, Malaysia
    #2
    Firstly, opening the application from the dock or Applications Folder does not make any difference.
    If you may, try opening the Application through Package Contents>Contents>MacOS

    That might work.
    One other possible reason why it isn't working could be because a file that is required to support the application is missing or you have upgraded your iWork Applications to support an OS X version different–basically you altered the files.
     
  3. palmharbor macrumors 6502

    Joined:
    Jul 31, 2007
    #3
    iWork is the most flawed WP App Apple ever created. They should have
    made reliable Appleworks for 10.8, I have trouble with the latest version
    all the time, especially naming a documents...ABC type stuff but the Geeks at Apple not obvious to them
     

Share This Page