iWork on Snow Leopard

Discussion in 'Mac Apps and Mac App Store' started by migulic, Sep 14, 2012.

  1. migulic macrumors member

    Joined:
    Mar 25, 2008
    #1
    I have a 2007 iMac running Snow Leopard on which I still have iWork 08. I would like to upgrade it to iWork 09 from the Mac App Store - however, the App Store says that OS X 10.7 is required (which seems quite weird to me - Lion wasn't even out yet when iWork 09 was released). Would I be able to run iWork 09 on Snow Leopard?

    The reason I want to do this is because I just got a new MacBook Air and I might buy iWork for that - it would be great if I could also get it running on the old iMac.
     
  2. JaHull macrumors member

    Joined:
    Apr 18, 2009
    Location:
    England
    #2
    You wont be able to install the Mac App Store version.
    If you can find a boxed copy you will be able to install that, just not be able to update to the newest version. (which is mainly just iCloud and Lion features)
    The latest update which ran on Snow Leopard was X.0.5 i think for each of the 3 pieces of software.
     

Share This Page