iWork, Pages always hides extension on export

Discussion in 'macOS' started by warutledge, Feb 25, 2010.

  1. warutledge macrumors newbie

    Joined:
    Dec 10, 2009
    Location:
    Bay Area
    #1
    Anyone have this problem? Export a Pages document to PDF or Word .doc always hides the extension in Finder. During the export, I have unselected "Hide extension" and it does show in the name dialog box, but listed in Finder, it's hidden. When I attach the doc through Gmail, the extension gets picked up, but some other web uploads it does not.

    This is really annoying, and I cannot get it to stop. Sure, I can Cmd+I and unhide the extension in Finder, but I shouldn't have to do that. As far as I can tell, it shouldn't hide. Finder is set not to hide extensions, too...

    I can't seem to find anything in the forums or online about it. Anyone have any advice?

    Thanks in advance.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Finder > Preferences > Advanced > Show all file extensions
     
  3. peg dash fab macrumors newbie

    Joined:
    Feb 27, 2011
    #3
    Still!

    I have had this problem forever, and I still have it. (Pages '09 version 4.1 (923), Mac OS X Version 10.6.8)

    (Enabling "always show extension" is not an answer — I want to be able to make this call on a file-by-file basis.)
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    You can't do it on a file-by-file basis.
     
  5. ScoobyMcDoo macrumors 65816

    Joined:
    Nov 26, 2007
    Location:
    Austin, TX
    #5
    Actually, you can hide the extension on a file-by-file basis. From finder, get-info - there is a checkbox for hide extension. I tried it and it only affected that one file.
     
  6. GGJstudios, Jan 10, 2012
    Last edited: Jan 10, 2012

    GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    I think they're talking about keeping that selection. AFAIK, you have to do that each time, as Finder won't remember your selection. It remembers the checkbox, but doesn't appear to act on it. Also, I just tried that, and it didn't work at all, even after relaunching Finder.
    ScreenCap 6.PNG

    OK, after experimenting some more, here's what I see.

    If you go to Finder > Preferences > Advanced and select "Show all file extensions", it appears to override the checkbox on individual files. So even if you check "Hide extension" in the Get Info window, it still shows, because the Preferences setting takes precedence.

    If you uncheck the Preference setting, then you can use the Get Info checkbox to show/hide the extension on individual files.
     
  7. peg dash fab, Nov 20, 2013
    Last edited: Nov 20, 2013

    peg dash fab macrumors newbie

    Joined:
    Feb 27, 2011
    #7
    GJStudios, I don't think you understand the complaint. In many apps, Pages included, the Save File dialog has a checkbox for Show/Hide Extension. And in all other apps (that I use, anyway), that checkbox works as advertised. But in Pages, PDF exports are always saved with the extension hidden, no matter how the checkbox is marked. This is a bug in Pages.
     

Share This Page