iPhone Jailbrake worked - but now iTunes won't synch with my 4S

Discussion in 'Jailbreaks and iOS Hacks' started by Netherscourge, May 25, 2012.

  1. Netherscourge, May 25, 2012
    Last edited: May 25, 2012

    Netherscourge macrumors 6502

    Joined:
    Oct 11, 2011
    #1
    :(

    (It synchs with my XP machine but not my Windows 7 machine?)

    Do I need to change some setting in iTunes on my Windows 7 machine to get it to connect?

    (Running the latest iTunes on all my machines.)

    I keep getting this error when I plug in my 4S to the USB:

    "itunes error 0xe8000012"
     
  2. The Tos macrumors 6502a

    Joined:
    Jan 5, 2011
    Location:
    Buffalo, New York
    #2
    I am getting the same error. I jailbroke my 4s with absinthe 2.0.1 for windows....now i get this when connecting to itunes...
     

    Attached Files:

  3. Netherscourge thread starter macrumors 6502

    Joined:
    Oct 11, 2011
    #3
    I just started a restore via DFU mode.

    Gonna do a clean 5.1.1 install from scratch and try Jailbreaking again later.

    I'll post my results later - taking FOREVER to download 5.1.1 from Apple...
     
  4. The Tos macrumors 6502a

    Joined:
    Jan 5, 2011
    Location:
    Buffalo, New York
    #4
    I did a restore and re jailbroke and itunes is able to see my phone. Sucks to have to go through it again but couldnt be more thankful of the guys who make the jailbreaks so user friendly. Good luck.
     
  5. Netherscourge thread starter macrumors 6502

    Joined:
    Oct 11, 2011
    #5
    I'll try it again tonight with Absinthe 2.0.4.

    Using 2.0.2 I could easily Jailbreak at work on an XP machine and the iTunes at work could connect to my 4S with no problem.

    But at home on my Win 7 machine, iTunes refused to connect to the phone.

    Maybe if I JB on my WIn 7 PC it'll work?

    Who knows...

    I'm back on standard 5.1.1 again. Gonna try again tonight at home.


    Thanks.
     
  6. TriJetHero macrumors 601

    TriJetHero

    Joined:
    Oct 13, 2010
    Location:
    World
    #6
    did you check your firewall settings under windows 7?
     
  7. Netherscourge thread starter macrumors 6502

    Joined:
    Oct 11, 2011
    #7
    I never had any issue with iTunes connecting to my 4S until after I jailbroke it.

    And I run everything as the Administrator anyway.

    It sees it fine when the 4S is running Apple's Official 5.1.1 iOS.

    When I jailbreak it and then try to connect to iTunes at home, it just gives me the connection error "itunes error 0xe8000012"

    The phone itself works fine when it's jailbroken - but with all my music and videos and photos stored on my Home PC, it's kinda pointless to have a jailbroken iPhone that I can't connect to via the USB to re-upload everything from.

    I'm guessing it may just be because I jailbroke and backed it up on a Win xp 32-machine at work and when I go home to synch all my stuff back onto my freshly jailbroken phone on my Windows 7 64-bit machine, it doesn't like it for some reason.


    Who knows.

    I prefer running the jailbreaks at work though - because I'm slightly paranoid about hacks embedded in the Jailbreak tools themselves and would rather use a "lab mouse" PC as opposed to my primary home PC with all my information on it.

    But that's just me.

    :)
     
  8. bikedog macrumors newbie

    Joined:
    Aug 27, 2012
    #8
    may need to re-restore & re-jailbreak

    had the same problem with different PCs - one able to see iphone & other being unable to see phone. Solved by restoring with custom IPSW, rerestoring my phone on PC that could see phone (thus 2 restores) and THEN jailbreaking. I didn't choose to set up as a new phone.

    The first time I'd just restored with the custom IPSW and quickly ran thru the phone setup. Upon jailbreaking I got a few errors & lost contacts, etc. It was at this point my other PC was unable to see the phone- however the other one was able to still detect the phone.

    Anyway, decided to restore again with the same custom IPSW, but chose to also restore the phone with a backup via itunes rather than set up as a new phone. All went fine (contacts, photos, etc) & I rejailbroke the phone with 14b2. It took a loooooonnnng time to set up but eventually got Cydia, etc installed & working, no errors. Today, I tried the other PC with iTunes which previously couldn't detect the phone- detected the phone with no errors & synced fine. My guess is this is a protection so that if someone doesn't get all your info if the phone is stolen. Also, I noted that getting the phone properly into DFU mode is a key.
     

Share This Page