Jailbreak 4.2 [stuck] help please.

Discussion in 'Jailbreaks and iOS Hacks' started by Sarmad, Jan 10, 2011.

  1. Sarmad macrumors newbie

    Joined:
    Jan 10, 2011
    #1
    hey
    my iphone 3gs which i updated by itunes to 4.2. i jailbreaked it through rednow now i have the new base band. When i was done jailbreaking it, it kept getting stuck on the apple logo, so i boot tethered !
    but after that every time i would turn it off..it would get stuck and i have to boot it again!
    now
    my phone is stuck with recovery mode. i tired jailbreaking it again through redsnow [cydia check] but it gets stuck on the bundle activation!
    please help

    what should i do? can i restore it? please let me know !
    thanks

    --
    i just tried to restore it to 4.2 error 1015
    and restore it to 4.1 error 1015

    what should i do?
     
  2. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #2
    The current jailbreak is a Tethered Jailbreak, so NEED to re run redsn0w everytime you boot, this is normal.

    You should be able to run Redsnow and get back up and running, but if something went wrong, you should be able to restore to 4.2.1 and re jailbreak there. Check your host file and make sure it is pointing to Apple.
     
  3. KevinC867 macrumors 6502a

    Joined:
    Jun 8, 2007
    Location:
    Saratoga, CA
    #3
    I have had similar problems. I did the 4.2.1 jailbreak with redsn0w. At first, it worked as expected. I could reboot into a non-jailbroken state, then I needed to run the tethered redsn0w re-break to run Cydia apps.

    However, after installing a Cydia app (I think it was MyWi, but could have been My3G), the required reboot landed me stuck at the apple logo screen. Fortunately, I can still get to DFU mode from there, so I can still do the re-break. But it's a bummer that a reboot disables the device until I can tether and re-break it.

    I guess I should try repeating the full redsn0w jailbreak and hope I regain the ability to keep running (non jail-broken) after a reboot.
     
  4. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #4
    That is NOT an issue, that is how it work, once you installed anything that use mobile subtrate, it will get stuck in the bootlogo since it cannot execute it. You need to run redsn0w each boot.
     
  5. KevinC867 macrumors 6502a

    Joined:
    Jun 8, 2007
    Location:
    Saratoga, CA
    #5
    Got it. Thanks for the explanation.
     

Share This Page