Jailbreak Apps won't open.

Discussion in 'Jailbreaks and iOS Hacks' started by jyj, Sep 11, 2009.

  1. jyj macrumors member

    Joined:
    Sep 11, 2009
    #1
    I have just jailbreaked for the first time and i'm having some problems.

    I ran redsn0w and also unlocked with yell0wsnow. i have a 3G running 3.0.1.

    I downloaded a couple apps in Cydia and that went off without a hitch - but the problem lies when I try to actually open the apps. I get a screen that looks like something is happening, but then it just shuts down and goes back to the springboard.

    I've tried restarting the phone - and tried it with a few different apps but with no luck.

    Is there possibly something that I haven't done correctly or a step that I'm missing?

    thanks for any help in advance!
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    For a 3G, you should have Jailbroke with Redsn0w and unlocked with Ultrasnow

    Go to iClarified and get a tutorial for 3G and follow it exactly.

    If you ran yellowsnow, that could be why your apps are not working. That is for older devices (2G phones)

    You will have to restore your phone first. There is a sticky here for that (top of page) Do not upgrade to 3.1.
     
  3. jyj thread starter macrumors member

    Joined:
    Sep 11, 2009
    #3
    thanks for the reply! i'll go back and retry it properly. hopefully that fixes it!

    edit: shoot. i just checked and i did in fact use ultrasn0w. any ideas what else I could have done wrong?

    edit again: nevermind...figured it out!
     
  4. captainemerica macrumors newbie

    Joined:
    Jul 21, 2010
    #4
    Hey,

    I've got this same problem on the 3g 4.01 software. How did you solve in the end?

    I jailbroke with Redsn0w and it seemed to complete fine. I've restored and tried jailbreaking again but still got the same problem.

    Apps like iNoRotate, asbattery and sbsettings work fine just apps that have their own icon open then shut down.

    I've tried hard reset etc.

    Cydia seems to work OK.

    Thanks for the help
     
  5. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #5
    Did you check to see if the apps are 4.0.1 compatible ? :confused:
     
  6. j3ts83 macrumors newbie

    Joined:
    Jul 19, 2010
    #6
    I am also having the same problem. I have rejailbroke it numerous times from different programs. I have come to the conclusions that 3G's just suck and the 4/4.0.1 operating systems only run well on 3GS's and 4G's.
     
  7. captainemerica macrumors newbie

    Joined:
    Jul 21, 2010
    #7
    Thanks for the responses.

    No, I didn't check if they were 4.01 compatible. It's the first time I've jailbroken my phone so I don't know how to check - is there a way to check in Cydia? I figured as apps that don't have their own icon were working it was something else wrong.
     
  8. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #8
    Not sure is this is still being kept up to date or not
     
  9. claire2327 macrumors newbie

    Joined:
    Apr 1, 2011
    #9
    Hello!

    I'm also new to jailbreaking and I'm having the exact same problem. My iphone was fine for a week or so and last night I downloaded a few apps from Cydia (Activator, AptBackup, Back to top contact, biteSMS, Bytafont, CyDelete,...) and now whenever I try to open a non Cydia app (like the facebook app for instance), it looks like it's launching but it goes back to the SB... The apps still show in the list when I double click the home button so they are not completely closed.

    Has anyone managed to solve this problem?

    Thanks!

    Claire.
     
  10. WhatAmI macrumors 6502a

    WhatAmI

    Joined:
    Sep 2, 2009
    #10
    Sounds like you need to connect it to a computer and all should be well again with your iTunes account.

    Open the iTunes app (not itunes on the browser, but the actual application)
    click "store"
    click "authorize computer"
    follow the instructions
    when finished sync your iphone
     

Share This Page