Jailbreak bricked my iPhone?

Discussion in 'Jailbreaks and iOS Hacks' started by iag48, Jan 20, 2012.

  1. iag48 macrumors regular

    Joined:
    Jan 26, 2008
    #1
    Guys I need a little help.
    I jailbroke my phone and everything was going great. I installed SBSettings and 3G Unrestrictor. I then tried to test a 3g FaceTime call and it failed. Then I received a "No Service" status. I tried rebooting, airplane on/off, reset network settings and finally Backup and Restore. iTunes downloaded the software to restore and I received an error, I think it was Error 21, and when I click on the link there is no information available.

    I have a Sprint iPhone 4s.

    Please help.

    Thanks.
     
  2. iag48 thread starter macrumors regular

    Joined:
    Jan 26, 2008
    #3
    Thank you for the link. Hopefully I can figure out a solution.
     
  3. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    Your device isn't bricked. To brick an iOS device, a person must actually be wanting to brick and know exactly what they are doing. Other then that, it is impossible to do so.

    Remove any listing for gs.apple.com from your hosts file (Google how). Restart your computer when done. Put your 4S into DFU mode (Google how) and restore it in iTunes.
     
  4. iag48 thread starter macrumors regular

    Joined:
    Jan 26, 2008
    #5
    Thanks for the information. I will do what you said when I get home in a couple of hours.
     
  5. iag48 thread starter macrumors regular

    Joined:
    Jan 26, 2008
    #6
    Hey Intell,

    I googled how to find and edit/remove the file but after I edit the file and drag it back to the folder I receive a message that the file cannot be moved because its in use.

    Any idea how to fix?
     
  6. iag48 thread starter macrumors regular

    Joined:
    Jan 26, 2008
    #7
    Well I used Terminal to delete the two files:

    74.208.10.249 gs.apple.com
    #127.0.0.1 gs.apple.com

    after I reboot the mac, I put my phone into DFU mode and then I get the 1600 error message. I then go and check the hosts file and the 2 files are still there.

    I don't know what to do now. Should I take it to the Apple store? will they know I jail broke it and won't service it?
     
  7. iag48 thread starter macrumors regular

    Joined:
    Jan 26, 2008

Share This Page