jailbreak iPhone 2g 3.1.3 - Error 6

Discussion in 'Jailbreaks and iOS Hacks' started by steigw, Jul 18, 2011.

  1. steigw macrumors newbie

    Jul 10, 2011
    I have an old iPhone 2g with 3.1.3 on it that I'm in the middle of jailbreaking. This iPhone has a broken power button so I can't use that button to put it into DFU mode. I found postings and followed them that had me upload a modified (corrupted) ipsw file that caused the phone to get put into DFU mode and there it sits.

    So I've tried jailbreaking with redsn0w and it fails precisely because redsn0w requires I use the power button to get into dfu mode. But the device is already in dfu mode and so this fails.

    I've used sn0wbreeze and this seems to work. I go through the entire process and end up with a snowbreeze ipsw file that I'm to upload via iTunes. The iPhone also has a snowflake picture with the words "waiting for custom firmware" on it at the end of the snowbreeze routine. Should be easy at this point shouldn't it!!

    Well I've tried to upload the custom ipsw file on two different computers using three different cables. Each time it seems to make it almost to the end and I then get an error message on iTunes saying the recovery failed due to an unknown error [6]. the screen on the iphone has gone black at this point and upon clearing the error message iTunes then informs me an iPhone is attached in recovery mode.

    I can't find much about an error 6 and am stuck. I tried to put back the original iTunes firmware at one point (i've been workin on this on and off for a week or so) and it restores just fine but wants me to activate the phone. Note it was activated before I started this little project.

    So I see lots of brillient people going over these forums and I don't see that the sn0wbreeze people have dedicated support forums so I'm hoping one of you can help me out.

    How can I get this old 2g iPhone jailbreaked?

Share This Page