Jailbreak: it just doesn't work

Discussion in 'Jailbreaks and iOS Hacks' started by MathijsDelva, Jul 24, 2009.

  1. MathijsDelva macrumors regular

    Joined:
    Feb 28, 2008
    #1
    Hello,

    I'm very new to this iPhone jailbreaking stuff. I have tried pretty much everything i found on the net including apps, tips and tricks, yet nothing works. Here's the deal:

    I bought a second hand iphone from this person. It's a 3G 16GB black one. It worked OK without a sim. Then of course, i put in my own sim which is isn't an official supported sim card (as itunes says so). Now i can't get passed the emergency call screen when the iphone is booted. After all my failed attempts, i'm beginning to wonder if it is possible to jailbreak my iPhone? The only thing i can do right now is restore to 3.0 through itunes after putting it in DFU and playing around in the emergency call screen.

    Can i jailbreak my iphone in this situation? Does my sim need to be in the iphone or doesn't it?

    Redsnow is just waiting for reboot, for the past 45 minutes. Unplugging it and plugging it back in didn't work. USB hub didn't work, .. I tried everything. I even tried redsnow for windows on another pc, didn't work either. I tried ziphone: gave an error. I tried pwnagetool: seemed to work but when it tells me to go in DFU, it's got it all wrong. The first step is to seemingly connect the iphone. I do that, but it doesn't go to the next step (turn off iphone). If i play around with it, pretending to be off, and holding the home & power button it looks like it's going to work until i get the error that DFU failed.

    I don't know what's wrong? How come's nothing working here? :s
    Help!
     
  2. kate-willbury macrumors 6502a

    Joined:
    Feb 14, 2009
    #2
    sounds like you do not know how to follow simple instructions.
     
  3. The General macrumors 601

    Joined:
    Jul 7, 2006
    #3
    Do you have a Mac or Windows?
    If you have a Mac, do you have Leopard 10.5.7 installed?
    Do you have iTunes 8.2.1 installed?

    What do you mean by "it's got it all wrong" when referring to pwnage?
     
  4. MathijsDelva thread starter macrumors regular

    Joined:
    Feb 28, 2008
    #4
    Yes, both.. And i have a mac.

    Edit: about pwnagetool. So when it's preparing to go into DFU mode, it's shows the steps to follow right?
    So first, attach iphone via usb to mac, then power off, then hold buttons for 10 seconds, ... But if i connect my iphone,
    it doesn't show the next step. It seems like pwnagetool doesn't recognize the iphone. So there is no next step, i'm stuck
     
  5. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #5
    Use redsn0w .0.8, much easier than PT

    You just need to make sure you have the Apple 3.0 restore firmware on your Mac. Should be in User/library/iTunes/Software****.
     
  6. MathijsDelva thread starter macrumors regular

    Joined:
    Feb 28, 2008
    #6
    Is that the one iTunes downloaded? It's there: iPhone2,1_3.0_7A341_Restore.ipsw

    But it's not that simple it seems, Redsn0w doesn't work. It's always stuck at "waiting for reboot", always, no matter what i try!

    edit: OMG! Just noticed something: that one says iPhone2,1. All the firmwares i've downloaded were iPhone1.2. Damn! I guess it'll work now? i'll try right now.. Thank god for random answers on a forum :)
     
  7. The General macrumors 601

    Joined:
    Jul 7, 2006
    #7
    EDIT: Ah, you already figured out that you had the wrong firmware. Try again, good luck!
     
  8. MathijsDelva thread starter macrumors regular

    Joined:
    Feb 28, 2008
    #8
    It actually worked. Omg.. I feel terribly stupid. Thank you guys, really, thank you!
     

Share This Page