jailbreak new 3g 3.1.3?

Discussion in 'iPod touch Hacks' started by FelixMC, Jun 1, 2010.

  1. FelixMC macrumors member

    Joined:
    Jan 4, 2008
    #1
    One of my friends wants me to try to jailbreak his iPod Touch after seeing what my 2G jailbroken ipod can do. He just got his last week, its a 3rd gen 8gig ipod, and I'm not sure if it came with 3.1.3 already on it, or if my friend accidentally updated it when he first plugged it into itunes, but it is running 3.1.3, which seems to be a problem. I downloaded the 3.1.2 firmware and did a restore from file in itunes and restored the ipod to 3.1.2. It booted up fine, I could browse the internet on it, added some songs to test it out and all that, it all seemed to work. Then I downloaded the latest blackra1n and jailbroke it without getting any errors or anything, but when it booted up, the iPod showed the "plug into itunes" screen and when I did so iTunes said that the ipod is in restore mode and must be restored and all that..I once again restored it to 3.1.2 and tried blackra1n again with the same result. Then I decided to try redsn0w so I restored it to 3.1.2 once again using itunes, then I downloaded the 0.9.2 redsn0w 3.1.2 pack from a torrent site, and tried to jailbreak it from there. Everything seemed to go fine, I was actually getting a little excited, the iPod was displaying the right icons for downloading the firmware and jailbreaking and all that, but once again when it booted itunes said it was in restore mode and needed to be restored in order to be used :(
    Im using iTunes 9.1 on a Windows 7 pc. I also have a G4 mac, but as far as I know most mac jailbreaking tools require intel.
    Are there any solutions for this? Are 3G ipod touches even jailbreakable or am I just wasting my time? Most tutorials for downgrading to 3.1.2 use a 2G ipod touch which had previously already been jailbroken. I don't mind erasing/restoring the ipod as many times as I need to, as there is literally nothing on it.
    Can anyone point me in the right direction, plz? :)
     
  2. The General macrumors 601

    Joined:
    Jul 7, 2006
  3. Gatorsxrule macrumors member

    Joined:
    Mar 21, 2010
    #3
    Also the plugin to to iTunes icon you got was because it was a tethered jailbreak which means that the program needed to be run again for it to boot up. But the one above, the "Spirit" jailbreak, is untethered, so you wont run into that problem with it
     
  4. FelixMC thread starter macrumors member

    Joined:
    Jan 4, 2008
    #4
    i love you guys!
    it took like 30 seconds to jailbreak it :)
    i wonder why Spirit doesn't get more google hits, since it actually worked, cuz I've never heard of it before prior to now, and I had been googling this for hours lol
     

Share This Page