jailbreak running 3.01 on 3gs? vs NCCA app

Discussion in 'Jailbreaks and iOS Hacks' started by rower, Mar 16, 2010.

  1. rower macrumors member

    Joined:
    Jan 6, 2009
    #1
    I kept my 3gs on 3.01 as I wanted the option of jailbreaking, if only to be able to use it for tethering.

    I decided to download the ncca march madness app so i could watch the games. Unfortunately it requires the latest release.

    So... what do I do? Should I jailbreak (and what are the instructions please?)?

    Will I then get the latest os and be able to buy the ncca app?

    many thanks!
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    If you were not previously JB and dont have your SHSH's saved thru cydia you cannot restore or update to anything but the latest 3.1.3
    And that version cannot be Jailbroken for a 3GS.
    so I'd say stay where you are for now, one app is not worth it.
    You can get all the NCAA live info thru safari.
     
  3. rower thread starter macrumors member

    Joined:
    Jan 6, 2009
    #3
    Maybe I wasn't as clear as I needed to be:

    I am currently on 3.01

    I would love to purchase the NCAA streaming app but it requires a current release to download.

    I want to tether my phone.

    What should I do? Any suggestions? Links to jailbreaking if needed. (I don't have cable tv so the app is the only way to get the video unless there is a way on the internet to get streaming video... but even then I wouldn't mind the portability)

    thanks!
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    What do you want to do?
    Upgrade to the latest 3.1.3 to get the App or JB?
    You dont need to JB to tether on 3.0.1
     
  5. rower thread starter macrumors member

    Joined:
    Jan 6, 2009
    #5
    What I would like to do?

    I guess both have the NCAA app (requiring the latest os) and be able to tether.

    Although, I have an itouch so I guess I could put the ncaa app on that instead, though it would be nice to have edge usage too.

    How do I tether without jailbreaking by staying on 3.01?

    And if I jailbreak (is it easy, I did it on my first generation 2g phone but not since?), can I then add the latest os to get the ncaa app?

    thanks again!
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    I see.
    You can't do Internet tethering on official 3.1.3.
    Only if you jb it.
    You will have to jb the current 3.0.1
    then create a custom 3.1.3 firmware with pwnagetool and then restore to the custom jb 3.1.3 ipsw assuming your device has the old iboot and not the latest tethered jb bootloader.
     
  7. Y2J macrumors newbie

    Joined:
    Mar 18, 2010
    #7
    The real answer is You don't need 3.1.3 to run the NCAA app

    I have a jailbroken 3.1.2 (MC serial'd so I cant go to 3.1.3 if i wanted with a custom install)

    I'm running the NCAA app no problem and have streamed games using the 3g Unrestrictor all day while working

    Edit:VV 3G Unrestrictor just fools it into thinking its on wifi to stream video.

    I am not spoofing 3.13, the NCAA app does not require it. And if he is jailbroken and working now, he can still save his SHSH on cydia for the 3.1.2 upgrade
     
  8. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    He will not be able to restore or update to anything but the latest 3.1.3 on his
    3GS since he doesnt have his SHSH's saved thru cydia.
    Im not sure if that JB spoof package that tricks your iphone to think its on 3.1.3 would work with 3.0.1 firmware but the hack is still very unstable and causes iphone crashes that need a restore.
     
  9. rower thread starter macrumors member

    Joined:
    Jan 6, 2009
    #9
    It does look like I can use 3.1.2 does that make a difference
    i am on 3.0.1 right now.

    Point me to how to jailbreak please?

    also how to tether if I decide not to jb.

    all the best and thank you!
     
  10. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #10
    You cannot restore or update to 3.1.2 on a 3GS that hasnt been JB before.
    You can either JB on your current 3.0.1 or update to official 3.1.3 with no Tethering or JB available.
     

Share This Page