Jailbreak successful, unlock not at all

vitiiphonenoob

macrumors newbie
Original poster
Jun 22, 2010
14
0
hi i jut needed some help on a small issue...i recently jailbreak-ed my phone with jailbreakme 2.0 and when i try unlocking it with ultrasn0w, i get an error message just before installation finishes saying that "could not activate cellular data network".... i have ios4 so i tried installing ultrasn0w with both the cellular data option on and off, but without any success....please help this way ill just have an expensive iphone which i havent made a single call on.....and i don't have AT&T as a carrier in my country :(
 

ooggaala

macrumors newbie
Aug 8, 2010
8
0
I think that ultrasn0w cannot be used with iPhones that are of a higher version that it was designed for. I currently jailbreaked AND unlocked my iPhone 3G. I don't know what your iphone is (1G, 2G, 3G, 3G S, or 4G). So I'll just give some links.

The one I used:
http://www.iclarified.com/entry/index.php?enid=4520
Needs cydia with it. I aussume since your iPhone is jailbreaked it has that.

The website:
http://www.iclarified.com/
Go to the bottom of the page and click the third icon that looks like a notebook with pencils > iPhone > Unlock > Find your iPhone there. The break only works if you use the right one -- if you have a 4G iPhone and try using one that says for 2G iPhones it obviously won't work.

Hope I helped!
 

ooggaala

macrumors newbie
Aug 8, 2010
8
0
I think that ultrasn0w cannot be used with iPhones that are of a higher version that it was designed for.
http://www.iclarified.com/ said:
These are instructions on how to unlock the iPhone 4, iPhone 3GS, and iPhone 3G for use with any GSM cellphone carrier using UltraSn0w. This will work with the iOS 4.0 firmware.

Before you can follow these instructions you must have a jailbroken iPhone and you must be on the 04.26.08, 05.11.07, 05.12.01, 05.13.04, or 01.59 baseband(modem firmware).
I was right. Ultrasn0w will NOT work with iOS 4.0 firmware because it is a higher version than it was designed for. You have iOS 4.0 firmware so it won't be able to work for you. You should check out the link I already posted above and follow it to unlock it.
 

moussekateer

macrumors 6502a
May 12, 2009
733
0
I was right. Ultrasn0w will NOT work with iOS 4.0 firmware because it is a higher version than it was designed for. You have iOS 4.0 firmware so it won't be able to work for you. You should check out the link I already posted above and follow it to unlock it.
Say what? ultrasn0w works for ALL basebands on ALL firmwares (apart from the 4.1 betas which you shouldn't have).

OP the 'could not activate cellular data network' error is most likely due to the phone having incorrect APN settings for your carrier.
 

Applejuiced

macrumors Westmere
Apr 16, 2008
40,672
6,531
At the iPhone hacks section.
I was right. Ultrasn0w will NOT work with iOS 4.0 firmware because it is a higher version than it was designed for. You have iOS 4.0 firmware so it won't be able to work for you. You should check out the link I already posted above and follow it to unlock it.
Dont post if you're not educated newbie.
Ultrasnow unlocks 4.0 and 4.0.1 basebands on 3G, 3GS and iphone 4
 

Rizvi1

macrumors 6502a
Mar 29, 2006
801
8
Maryland
...
OP the 'could not activate cellular data network' error is most likely due to the phone having incorrect APN settings for your carrier.
How do you resolve the problem (Assuming I'll encounter it) of incorrect APN settings for the iPhone once you unlock and go with t-mobile? That's what I'm planning on doing with the 3GS I'm hoping to pick up soon
 

moussekateer

macrumors 6502a
May 12, 2009
733
0
How do you resolve the problem (Assuming I'll encounter it) of incorrect APN settings for the iPhone once you unlock and go with t-mobile? That's what I'm planning on doing with the 3GS I'm hoping to pick up soon
You search the forum or Google for the settings, and then put them in at Settings-General-Network-Cellular Data Network (That last part might be differently worded for American phones).
 

vitiiphonenoob

macrumors newbie
Original poster
Jun 22, 2010
14
0
info about iphone...and details of jailbreak

firstly i just want to thank you for replying to my post so quickly...secondly...i apologise for not providing the details of my iphone...

well i have a 3 month old, out of the box apple iphone 3GS...it initially had iOS3.1.3 which i jailbreaked using spirit jailbreak and then tried unlocking but kept receiving the same "could not activate cellular data network" error....i even tried restoring and rejailbreaking again but by this time apple had stopped signing iOS 3 so i had no choice but to upgrade to iOS4...i know i shouldn't have done that but that was the only option i had...well just last week i discovered the jailbreakme option so i tried it straight away...the jailbreak went flawlessly, given that i followed the instruction of "not doing anything stupid" very strictly.

well after jailbreak i installed ultrasnow 1.0-1 from the repo "repo666.ultrasn0w.com", and this is where i encountered the error message.

what do i do next, i have uninstalled ultrasn0w and tried reinstalling it with the option under Setting>General>Network>Cellular data both on and off but still no success...i have a screenshot of when the error actually shows up

and i think the most vital piece of information i have to tell is that i don't have AT&T or TMobile in my country....as i live in Fiji and we have Vodafone and Digicel network as mobile phone carriers
 

anthdci

macrumors 6502a
Jun 8, 2009
609
188
are you on 4.0 or 4.0.1? ultrasn0w has been updated recently to cover that baseband. It is now version 1.1-1 so try it again with the new version
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.