Jailbreak/Unlock 2G iclarified questions

Discussion in 'iPhone Tips, Help and Troubleshooting' started by yelsew, Jun 19, 2011.

  1. yelsew macrumors newbie

    Joined:
    Jun 19, 2011
    #1
    I have been trying to unlock a 2G iphone to use on Tmobile. I have read many threads and tried using iclarified instructions. The phone has 3.1.3 and I am following the instructions at Iclarified based on that. I am trying to use redsn0w, but when I get down to step 6 it says the firmware is not verified. Here where I am confused. At the beginning of the tutorial, it had me download 4 files. Within the tutorial it only references those files, but if you look closely at the picture the IPSW files are different. The 1st restore uses 3.1.3 but step 5 refers to a 3.1.2 software (only in the picture, there is no written reference to it).
    Am I supposed to download a different software for this step or use the same 3.1.3 that I downloaded per the instructions?
    If I am supposed to use the same, why doesn't it recognize it? It worked for the restore?
    If I am supposed to use the 3.1.2 why didn't the mention to download it in the instructions?

    Thanks in advance for your help.
     
  2. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #2
    iOS 3.1.3 and 3.1.2 were basically the same, so redsn0w interprets them that way. If your 2G is on 3.1.3 just use the 3.1.2 firmware and load it into redsn0w.
     
  3. flyingninjas macrumors member

    Joined:
    Jan 27, 2011
    #3
    to unlock you have to unlock a baseband,not a firmware. firmware versions are 3.1.2 and 3.1.3 while baseband is like 5.11.02 or something. what is your baseband? settings -> about will tell u. then google "unlock <enter baseband version here>"
     
  4. yelsew, Jun 19, 2011
    Last edited: Jun 19, 2011

    yelsew thread starter macrumors newbie

    Joined:
    Jun 19, 2011
    #4
    Redsnow crashed around step 11 while it was doing the jailbreak process (or thats what windows said)

    My phone now says downloading Jailbreak data, redsnow is crashed and I am thinking that the phone is just stuck there.

    How long should i wait? Should I try a reboot? Suggestions?


    Update - I didnt wait long. Rebooted Iphone. Redid the process. It worked this time, no crash. The instructions in iClarified and in redsn0w about the amount of time required to hold the buttons is incorrect. Step 3 calls for 30 seconds but it only takes about 10 or so. Phone is rebooting now.
     
  5. yelsew thread starter macrumors newbie

    Joined:
    Jun 19, 2011
    #5
    It worked second time around.

    Popped in my TMobile SIM and made calls!

    Now I dont know if I was supposed to download BootNeuter and run it or not. I had run it before and didnt feel like it worked, but that might have been my own screw up because I tried using Spirit to jailbreak and then Bootneuter, but had an old ATT activated SIM in there and that may have been my problem.

    The key lesson I learned is to NOT activate your phone on ITunes before you run jailbreaks and unlocks if you want to switch to Tmobile.

    Your mileage may vary.
     

Share This Page