Jailbreaking 2.2.1 error

Discussion in 'Jailbreaks and iOS Hacks' started by clearchaos, Feb 8, 2009.

  1. clearchaos macrumors regular

    clearchaos

    Joined:
    Feb 8, 2009
    #1
    hey guys, this is my first post so hopefully somebody can help me.
    i'm on windows, and i have a 16gb iPhone 3G with firmware 2.2.1 installed. i wanted to re-jailbreak my iPhone after the upgrade, so i downloaded the quickpwn update from http://www.installerapps.com/2009/01/27/jailbreak-221/ and ran it using quickpwn. quickpwn runs fine, but when i try to jailbreak using the 2.2.1 firmware, i get an error saying "Firmware error string."

    does anyone have an idea why this is happening? i know it's a legit .ipsw file (i've used it to restore my iphone with itunes before) so i'm not sure why this is happening.
     
  2. Knowlege Bomb macrumors 603

    Knowlege Bomb

    Joined:
    Feb 14, 2008
    Location:
    Madison, WI
    #2
    Can't tell you why but I can tell you how to fix it.

    Start over. Restore your iPhone. Delete and re-download quickpwn. Jailbreak. ;)
     
  3. clearchaos thread starter macrumors regular

    clearchaos

    Joined:
    Feb 8, 2009
    #3
    i've already restored and tried it again, but to no avail.
    i'll redownload quickpwn and the update, crossing my fingers the whole time.

    edit: thanks lp. i downloaded the new quickpwn (rather than just a patch) and it works! iphone 2.2.1 is succesfully jailbroken :D
     
  4. Tokiopop macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
    #4
    I had errors jailbreaking 2.2.1 aswell, but on the 3rd try it worked :p
     
  5. scavengerbmx macrumors newbie

    Joined:
    Feb 8, 2009
    #5
    just restore and try again. i just jailbreaked my iphone 3g 2.2.1 1st time didnt work 2nd time did
     
  6. Wisenos macrumors newbie

    Joined:
    Aug 28, 2008
    #6
    2nd try here and jailbreak sucessfull but when reboot stuck on apple's logo

    so for me jailbreaking is done...
     

Share This Page