Jailbreaking my 3GS to OS4 help!!

Discussion in 'Jailbreaks and iOS Hacks' started by someguy66, Aug 31, 2010.

  1. someguy66 macrumors newbie

    Joined:
    Aug 31, 2010
    #1
    i recently tried to update my already jailbroken and unloked 3.1.2 firmware to 4.0.. but itunes wouldnt restore to the file made through snowbreeze, then i restored normaly through itunes back to the latest firmware. 4.0.2 i think

    now itunes says i need a valid sim to activate so i cant get into it to jailbreak/unlock

    please help, im all out of ideas
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Do you know if you have SHSH's saved thru cydia for previous builts?
    If not you will not be able to JB or unlock it on 4.0.2
     
  3. someguy66 thread starter macrumors newbie

    Joined:
    Aug 31, 2010
    #3
    yes i think i did save them on cydia by memory...
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    If you did then download the official 4.0.1, edit your hosts file to redirect to cydias server for the shsh check and restore it thru itunes by selecting the 4.0.1 ipsw and not the official 4.0.2 that itunes would want to update you to.
     
  5. someguy66 thread starter macrumors newbie

    Joined:
    Aug 31, 2010
    #5
    would it be 4.0.1 or would it be 3.1.2? coz i went from 3.1.2 to 4.0.2... cydia would have only saved the old ones?
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    Nope, if you clicked "make my life easier" on cydia it would have started at 3.1.2 and would have got all SHSH's for you up till the latest 4.0.2 even though you were never on them.
     
  7. someguy66 thread starter macrumors newbie

    Joined:
    Aug 31, 2010
    #7
    ok great, the only thing i dont understand is "edit your hosts file to redirect to cydias server" .. im a bit lost on that :S
     
  8. NickkyJ macrumors regular

    Joined:
    Aug 29, 2010
  9. someguy66 thread starter macrumors newbie

    Joined:
    Aug 31, 2010
    #9
    so does that mean that 4.0.1 is JB and unloackable...while 4.0.2 isnt?
     
  10. someguy66 thread starter macrumors newbie

    Joined:
    Aug 31, 2010
    #10
    ok thats all done, but now i get " need a valid sim card" msg and cant get past the emrgency phonecall screen, any ideas?
     
  11. WhatAmI macrumors 6502a

    WhatAmI

    Joined:
    Sep 2, 2009
    #11
    Hook up your iPhone to iTunes. You need to activate your phone with the original SIM-card from the service provider the iPhone was sold through. If you do not have that handy your other option is a Phonebook card
     
  12. someguy66 thread starter macrumors newbie

    Joined:
    Aug 31, 2010
    #12
    ok great, just to clarify.. do i need the ORIGINAL sim card? or can i borrow a sim card from the same carrier off a friend?
     
  13. WhatAmI macrumors 6502a

    WhatAmI

    Joined:
    Sep 2, 2009
    #13
    You can borrow a SIM-card as well and your friend won't risk anything by ledning it to you.
     
  14. someguy66 thread starter macrumors newbie

    Joined:
    Aug 31, 2010
    #14
    just bought a cheap $2 sim card from the corner shop, from the proper carrier and it activated no problem, it is just restoring now from my old backup.... once this is done, what is my next move?.. i heard jailbreakme.com is good for my jailbreak, but what about unlocking it so i can use my old sim card?
    thanks guys.
     
  15. someguy66 thread starter macrumors newbie

    Joined:
    Aug 31, 2010
    #15
    just download cydia and ultrasnow and now it is working fine with 4.0.2, thanks so much for the help, Applejuiced and WhatAmI.... been searching all day for a solutuon, thanks again. i hope this helps others
     
  16. WhatAmI macrumors 6502a

    WhatAmI

    Joined:
    Sep 2, 2009
    #16
    Your're welcome. You did all the hard work - we just pointed you in the right direction :)

    btw, you're not on 4.0.2 but rather 4.0.1. Stay there :p
     

Share This Page