Jailbreaking troubles

Discussion in 'Jailbreaks and iOS Hacks' started by first-earth, Apr 30, 2012.

  1. first-earth macrumors newbie

    Joined:
    Apr 30, 2012
    #1
    Hi guys.
    First off im new to all this iphone shenanigans and stuff but I'm pretty tech savie about stuff.
    I have an Iphone 3gs (produced in 2009) which is a hand down from my father which i obviously had to jailbreak to make it accept my simcard.
    This was done a few months back using redsnow and ultrasnow on 5.0.1 with the ipad baseband.

    Everything was more or less ok to start with, although occasionally the phone would not boot as jailbroken, meaning that it wouldnt accept the sim card and the cydia would crash immeadiately on opening. but this was only occasional.

    Then after some time it started sporadically restarting, which was annoying and worsened the earlier mentioned side effect.

    I decided that now a jailbreak was possible for 5.1 to try to upgrade to see if the problem would resolve itself.
    I downloaded the official ipsw and used redsnow to make a custom version. then entered into Pwned DFU using redsnow, and performed the restore from itunes.

    Now here is when the problem started. i seem to be stuck in a DFU loop which i can't get out of. if the phone is not connected to a power source it lasts maybe ten minutes and then tries to restart, which is what would happen before but was occasional, now its constant.

    when it does this restart/crash it cant return to the ios because it goes back into DFU on its own. I know it does because i see it reconnect to the computer even though the device screen is off. and also redsnow detects it in DFU mode.

    i can use redsnow just boot to start it back up again but it keeps going through the same problem constantly.

    I've tried googling all over but not found anything as specific as what my problem is. all the tutorials and vids just assume that everthing has worked out fine and give little other insight.

    I apologise for the long post and all and appreciate if youve stuck with me to the end. Heres what i'm thinking. I should try and just do an official factory restore from inside itunes to try and confirm if its a jailbreak problem or a hardware problem, but can i do that on a 2009 3gs with the ipad baseband?
     
  2. 3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #2

    I don't know how to fix this but I know that after installing the iPad baseband you can never install stock firmware so that won't work.
     
  3. Kyotoma macrumors 68000

    Kyotoma

    Joined:
    Nov 11, 2010
    Location:
    Carnegie and Ontario
    #3
    You have to cook a NO_BB firmware and then restore using that, then reflash the iPad baseband and use the Ultrasn0w fix to unlock your iPhone.
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Make sure you put your iphone in "pwned" dfu mode before attempting to restore to custom ipsw.
    Or else it wont work.
     
  5. first-earth thread starter macrumors newbie

    Joined:
    Apr 30, 2012
    #5
    Ok pretty much everything that you've all said is what i did. But i still get the fun entering dfu mode every time it starts and holding the power and home buttons will not exit DFU mode
     
  6. first-earth thread starter macrumors newbie

    Joined:
    Apr 30, 2012
    #6
    Well i'm guessing its truly dead now.
    the phone will only work when connected to a pc and even then the screen only ever shows up all white and nothing else.
    tried to restore with a custom ipsw and got an error 28.
    So what do you think? is it all over?
     

Share This Page