Jailbreaking With RedSn0w

Discussion in 'Jailbreaks and iOS Hacks' started by wrkactjob, Apr 9, 2010.

  1. wrkactjob macrumors 65816

    wrkactjob

    Joined:
    Feb 29, 2008
    Location:
    London
    #1
    Hi I am starting to jailbreak my 3.1.3 with RedSn0w using this guide on iClarified

    http://www.iclarified.com/entry/index.php?enid=7443

    Have downloaded the 3.1.2 restore but it looks different to the one in the diagram, once I launch RedSn0w which file should I be opening in Step 5?...it looks different?



    [​IMG][/IMG]
     
  2. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #2
    You have unzipped the ipsw. Don't do that. What you downloaded isn't really a zip file. The entire file you downloaded (even though Windows is mistaking it for a zip file) is what you need to click on in redsn0w.
     
  3. wrkactjob thread starter macrumors 65816

    wrkactjob

    Joined:
    Feb 29, 2008
    Location:
    London
    #3
    OK so I deleated the unzipped files from the Pwnage folder and simply dragged in the Zip file.

    it still doesnt look like the little cube in Step 5 though?

    But OK when I fire up RedSn0w and browse to my Pwnage folder I see a file called Firmware and inside that are two files called dfu and all_flash.

    This isnt right is it?....

    I think you can see for yourself if you quickly try to download the link in the script

    3.1.2 (3G): iPhone1,2_3.1.2_7D11_Restore.ipsw
     
  4. wrkactjob thread starter macrumors 65816

    wrkactjob

    Joined:
    Feb 29, 2008
    Location:
    London
    #4
    ANyone know of an alternative source for the 3.1.2 firmware file as I cant get this to work.
     
  5. profets macrumors 68040

    Joined:
    Mar 18, 2009
  6. tmatthews14 macrumors regular

    Joined:
    Feb 12, 2010
    Location:
    Utah
    #6
    Just click the link, and download it to your desktop. It should save as a .ipsw file. Dont mess with any unzip or unrar files. Just leave the file there.

    Then open Redsn0w, and browse for your .ipsw, and it should work fine.

    dont unzip anything.
     
  7. wrkactjob thread starter macrumors 65816

    wrkactjob

    Joined:
    Feb 29, 2008
    Location:
    London
    #7
    Yeah but this is just the same! it downloads as a Zip file not like the file in the video tutorial, did you unzip it or just drag the whole thing into your Pwnage folder?....
     
  8. wrkactjob thread starter macrumors 65816

    wrkactjob

    Joined:
    Feb 29, 2008
    Location:
    London
  9. wrkactjob thread starter macrumors 65816

    wrkactjob

    Joined:
    Feb 29, 2008
    Location:
    London
  10. tmatthews14 macrumors regular

    Joined:
    Feb 12, 2010
    Location:
    Utah
    #10
    Oh... Well click on it to rename it and instead of a .zip, erase it and type .ipsw.
     
  11. wrkactjob thread starter macrumors 65816

    wrkactjob

    Joined:
    Feb 29, 2008
    Location:
    London
    #11
    Didn't really do anything renaming the file, open it it looks like this:

    [​IMG][/IMG]
     
  12. profets macrumors 68040

    Joined:
    Mar 18, 2009
    #12
    its downloading fine, just leave it there and dont try opening it.

    open Redsn0w, and browse to the file
     
  13. wrkactjob thread starter macrumors 65816

    wrkactjob

    Joined:
    Feb 29, 2008
    Location:
    London
    #13
    No when I try to browse to it, IE when windows is searching for a file type .IPSW it can not find it.
     
  14. tmatthews14 macrumors regular

    Joined:
    Feb 12, 2010
    Location:
    Utah
    #14
    Redsn0w looks for an .ipsw file, not a .zip file.


    Okay, try this. go to control panel, switch it to classic view, look for folder options, click on the view tab, and check the box that says "Hide extensions for known filetypes"

    Then go back and try to rename it to .ipsw.
     
  15. wrkactjob thread starter macrumors 65816

    wrkactjob

    Joined:
    Feb 29, 2008
    Location:
    London
    #15
    no just doesn't see it!...in the original tutorial if you look at the video the file downloads as a kinda cube on the guys desktop not a Zip file, why is that?

    [​IMG][/IMG]
     
  16. tmatthews14 macrumors regular

    Joined:
    Feb 12, 2010
    Location:
    Utah
    #16
    You went through the control panel and changed what I said right?
    What are internet browser are you using to download the file?
    I'd suggest trying a different browser.

    Looks like you've got Safari, and IE. Try IE.
     
  17. profets macrumors 68040

    Joined:
    Mar 18, 2009
    #17
    are you using IE to download? can you take a screenshot while in the browser with the Save/download file window open?
     
  18. wrkactjob thread starter macrumors 65816

    wrkactjob

    Joined:
    Feb 29, 2008
    Location:
    London
    #18
    Ah guys!...I was using IE8, did as you suggested and tried Safari and hey presto...I owe you a beer...oh wait I'm in the UK, nevermind, if you get over this way! ;-)

    [​IMG][/IMG]
     
  19. tmatthews14 macrumors regular

    Joined:
    Feb 12, 2010
    Location:
    Utah
    #19
    Ah... good to hear. Good luck with the jb!
     
  20. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #20
    The problem is that IE thought it was a zip file (based on its mime type) and was changing the extension. If you had done what tmatthews14 suggested it would have fixed it. But using Safari or Firefox also works.
     
  21. wrkactjob thread starter macrumors 65816

    wrkactjob

    Joined:
    Feb 29, 2008
    Location:
    London
    #21
    Yeah thanks to you both for the advice, the JB went perfectly and I have now changed my SMS tones and now love them instead of hate them!

    I'm very happy.

    :D
     
  22. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #22
    Boy this thread went about 10 posts longer than necessary.

    If posters would/could just follow instructions :rolleyes:
     

Share This Page