Jailbreaking

Discussion in 'Jailbreaks and iOS Hacks' started by halisray, Aug 11, 2010.

  1. halisray macrumors regular

    Joined:
    Nov 7, 2009
    Location:
    MTL
    #1
    Hey,

    So I am getting my first iphone soon, the iphone 4.

    How do I Jailbreak it? I heard some issues with jailbreaking and the IOS update?

    Can someone explain?

    Thanks
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    Most likely your new iPhone 4 will come with 4.0.2, which at this time cannot be jailbroken.
     
  3. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #3
    I suggest you read one or two of the many threads already here on this exact subject.

    You cannot use jailbreak.me on 4.0.2
     
  4. atrac7 macrumors regular

    Joined:
    Jun 14, 2010
    #4

    Sadly if already do not have the iPhone 4 and it hasn't shipped out yet, you will more than likely end up with the 4.0.2 update that Apple has just released. You'll be barred from jailbreaking as there isn't one out for that update yet.

    If however somehow you pull off an iPhone with 4.0 or 4.01 you can just go to jailbreakme.com and it's rather self explanatory after that.
     
  5. halisray thread starter macrumors regular

    Joined:
    Nov 7, 2009
    Location:
    MTL
    #5
    okay cool thanks - do you think there will be some Jailbreaking software for the 4.0.2 update soon? or is it now impossible?
     
  6. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #6
    Only speculation here...

    With 4.1 firmware soon to drop, I don't see the DevTeam wasting an exploit (assuming they have another one) to jailbreak a firmware version that will be obsolete in maybe 3 to 5 weeks.

    Besides that, 4.0.2 was released only to patch the jailbreak.me exploit. I don't see (hopefully) too many jailbreakers upgrading to it. Only those with new iDevices and those who have to restore with no hashes saved will be on 4.0.2
     
  7. Naked Snake macrumors member

    Joined:
    Jul 2, 2008
    Location:
    Los Angeles,CA
    #7
    if you can find the ios 4.0 link somewhere and download it then u can use redsn0w to jailbreak and select 4.0 instead of 4.0.2. ive tried this and it works cause i had to restore my iphone and got stuck with 4.0.2 which im still on but i have wallpapers, cydia, and multitasking on iphone 3G.
     
  8. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #8
    I think OP is asking about an iPhone 4

     
  9. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #9
    Chances are the phone won't come with 4.0.2 since it's too new.

    Jailbreaking iOS 4.0.2 is not available at this time for iPhone 4's.
     
  10. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #10
    Perhaps, but when he said soon, I assumed (perhaps incorrectly) OP hasn't ordered the phone yet.

    With this jailbreak exploit, my guess is Apple will be quick to put 4.0.2 on all new phones being sold. But, perhaps not.
     
  11. Rajani Isa macrumors 65816

    Rajani Isa

    Joined:
    Jun 8, 2010
    #11
    They might not put that in new phones - relying on the customer to upgrade.

    It would change the production lines (however little time it might take) so they probably won't install a new OS version at the factory until 4.1

    So, halisray : when/if you get that iPhone 4, DO NOT UPGRADE it when you plug it into iTunes - check the firmware version already on the phone, and report back to this forum :)
     
  12. Benito macrumors 6502

    Benito

    Joined:
    Jan 5, 2010
    Location:
    Toronto, Canada
    #12
    I just picked a up an iPhone 4 today. It did not have 4.0.2 on it. I only upgraded to it when I was syncing my phone. Just so you know.

    Any advice though on jailbreaking a 3G iPhone with ios 4.0.2? I have to jailbreak it to let my partner use it with another carrier.
     
  13. moussekateer macrumors 6502a

    moussekateer

    Joined:
    May 12, 2009
    #13
    Look up redsn0w
     
  14. tflournoy95 macrumors 6502

    Joined:
    Sep 21, 2009
  15. murdercitydevil macrumors 68000

    murdercitydevil

    Joined:
    Feb 23, 2010
    Location:
    california
    #15
    pretty sure that only works on 4.0.2 if its running on a 3G/ipt
     
  16. moussekateer macrumors 6502a

    moussekateer

    Joined:
    May 12, 2009
    #16
    Neither Spirit nor jailbreakme.com work with 4.0.2

    But he was asking about an iPhone 3G :p
     
  17. tflournoy95 macrumors 6502

    Joined:
    Sep 21, 2009
    #17
    thats sucks now i have to wait for spirit to update before i can add music. i would never use jailbreak me though. too insecure.
     
  18. 20vturbo macrumors newbie

    Joined:
    Aug 13, 2009
    #18
    I have version 4.0 on my iphone 4 at the moment. Is there any reason or anyway to upgrade to 4.0.1 before jailbreaking? Or should I just keep it version 4.0 and use jailbreak.me
     
  19. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #19
    Just JB 4.0 through jailbreakme.com . 4.0.1 only changes how your signal looks. No biggie. Plus, I don't think Apple is signing firmware 4.0.1 anymore. Thus, you can't restore to anything other than 4.0.2, and since you can't JB that, 4.0 is still the way to go.
     
  20. moussekateer macrumors 6502a

    moussekateer

    Joined:
    May 12, 2009
    #20
    Just use jailbreakme.com and install Saurik's PDF exploit patch from Cydia. jailbreakme.com doesn't make your phone insecure, the exploit is present in ALL firmwares apart from 4.0.2.
     
  21. 20vturbo macrumors newbie

    Joined:
    Aug 13, 2009
    #21
    thanks for the info man!
     
  22. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #22
    there is even a fix in cydia for the signal look if it's a big deal to you. I can look it up if you want. I just exchanged my I4 at Apple it has 4.0 on it. so it will stay 4.0 for a while now!
     
  23. tflournoy95 macrumors 6502

    Joined:
    Sep 21, 2009
    #23
    ive already updated to 4.0.2. i stopped veiwing pdfs on my ipod just because of that huge hole in security. and apple's track record on security isnt exactly perfect either. i cant believe they would let such a huge hole go un fixed for so long. back in the days on iphone os 1 there was an over the air jailbreak that patched the hole for you since you couldnt rely on apple to do it.
     

Share This Page