Jailbroken 3G wifi problem

Discussion in 'Jailbreaks and iOS Hacks' started by kreuzberg, Jul 14, 2009.

  1. kreuzberg macrumors member

    Joined:
    Apr 23, 2009
    #1
    I've just got a 3g so I can jailbreak and unlock it to use my vodafone sim. So far I've jailbroken it using Pwnage Tool, found my wifi network and connected to it and the wifi signal has appeared in the top left as usual but when I try to use safari or cydia it says it is not connected to the internet.

    This wouldnt be such a problem except that I need to use cydia to use ultrasn0w. Does anybody know whats wrong or if i can unlock it through my mac without having to use the iphones wifi?

    Any help would be greatly appreciated, thanks!
     
  2. isaaclimdc macrumors 6502

    isaaclimdc

    Joined:
    Jun 28, 2009
    Location:
    Pittsburgh, PA
    #2
    Hm. Maybe if you tried jailbreaking / unlocking it using redsn0w instead of PwnageTool?
     
  3. kreuzberg thread starter macrumors member

    Joined:
    Apr 23, 2009
    #3
    I've just tried redsn0w and it seemed to work but then when the phone restarted, all the icons for the homescreen wernt there, even the bar at the bottom was gone so I'm having to restore it.

    Can anyone help??
     
  4. kreuzberg thread starter macrumors member

    Joined:
    Apr 23, 2009
    #4
    I've just used redsn0w again and this time it has jailbroken it and everything works but I'm still getting the same problem with the wifi. Does anyone know how to fix it, or unlock over usb??
     
  5. kreuzberg thread starter macrumors member

    Joined:
    Apr 23, 2009
    #5
    Anyone got any ideas, I cant use the thing til I can unlock it! :p
     
  6. kreuzberg thread starter macrumors member

    Joined:
    Apr 23, 2009
  7. kreuzberg thread starter macrumors member

    Joined:
    Apr 23, 2009
  8. iJustin15 macrumors newbie

    Joined:
    Jul 22, 2009
    Location:
    Michigan
    #8
    Jailbroken iPhone

    I used redsnOw to jailbreak/unlock and I was having a ton of problems with my 3g and Wifi. I went through my settings and deleted some applications on Cydia, one specifically called "BossPrefs" and it fixed everything. I have not had a problem since. feel free to contact me if you have any questions and I can try to help.
     
  9. kreuzberg thread starter macrumors member

    Joined:
    Apr 23, 2009
    #9
    Hi Justin, I just tried to PM you but it says you dont accept them.

    Thanks for the reply anyway, I was beginning to think no-one was going to help!

    Basically where I'm stuck is that I've jailbroken it with redsn0w and then I've tried to unlock it using cydia. It says its connected to my wifi network and the wifi symbol appears in the top left of the screen, but when I try to use anything involving wifi (safari, mail, cydia) it says it is not connected to the internet. Normally It wouldnt bother me but I need to use cydia to unlock it as I have a contract with another mobile carrier.

    I've tried to about 6 times so far with both quickpwn and redsnow and both ways give the same problem.

    You said you went into cydia and deleted "BossPrefs", i cant find this, where is it located?

    Thanks for the help
     

Share This Page