iPhone jailbroken apps

Discussion in 'Jailbreaks and iOS Hacks' started by franky116, Apr 27, 2013.

  1. franky116 macrumors newbie

    Joined:
    Apr 27, 2013
    #1
    Hello
    I recently had to revert back to my old mobile which happens to be an I phone 3G
    I tried to download and install certain Apps among which were Viber and Whatsap but it came up saying unable to update I phone software.

    After some research it appears that Apple do not support this older version of phone anymore (version 4.2.1) as that way they can con you into buying a newer phone
    I went and jailbroke my phone thinking I could do it that way but when I go into the menu it still says version 4.2.1 with firmware 05.15.04 and when I try to install Viber it comes up saying need newer version ?

    So my question is how do I do it ??? or am I missing something obvious as thought I could download the apps and install them

    Big thank you to anybody who can give me an idiots guide
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    Newer apps require newer firmware versions plus newer processors and more RAM.
    You cannot run them on outdated firmware (4.2.1) or devices.

    Even if you change the .plist and get them installed, they will crash when you launch them.

    As with any product, if you want the newer features, you will need current hardware and firmware.
     
  3. franky116 thread starter macrumors newbie

    Joined:
    Apr 27, 2013
    #3
    So am I correct in assuming that I was wasting my time jail breaking the phone as going by the apps etc available I can not see any great benefit as i just want a phone to do what a phone does, but a few little extras like whatsap and viber save a few quid for texting and handy when im away.
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    Jailbreaking will not allow the use of new iTunes apps on older hardware.
     
  5. franky116 thread starter macrumors newbie

    Joined:
    Apr 27, 2013
    #5

    So the question I now have is

    Can you get older versions of apps ? and if so where please as going to main sites or apple etc all come up saying need newer version

    Or is there something else out there that I can use as did try a few but nothing seems to be like those 2

    Or 3rd choice can I do something else to my phone that will allow me to use newer version of apps

    Thanks for the reply's so far guys
     
  6. braddick macrumors 68040

    braddick

    Joined:
    Jun 28, 2009
    Location:
    Encinitas, CA
    #6
    I recently used an iPhone 3G and still had the older Starbucks app loaded on it but guess what?
    As it is no longer supported, doesn't work.

    So, even if you locate some older apps there is a likelihood they still won't function correctly if at all.
     
  7. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #7
    There's no way to get older apps. One way is to keep the .ipa file that gets moved to the recycle bin when you sync newer versions of apps from your device to iTunes. The alternative is to download an older cracked version (not promoting piracy, I'm assuming these apps are free) and install that on your device

    Even if you somehow get the app to install on your device, it may not work because your device is too old and the hardware doesn't support the software. Or as someone mentioned, some have a "server" check so you need to have a certain version or else the app won't work.

    Unfortunately, there's pretty much no way to get apps to support an old device
     

Share This Page