Jailbroken ATV2 (4.4.4) resets screensaver settings?

Discussion in 'Apple TV and Home Theater' started by qwerty3089, Mar 21, 2012.

  1. qwerty3089 macrumors newbie

    Joined:
    Feb 10, 2012
    #1
    I have a jailbroken ATV2 with FW version 4.4.4. It's running the latest version of XBMC. It's also using ATVFlash.

    Anyway, as most people here have probably experienced, XBMC is pretty unstable on the ATV. It crashes back to the ATV main menu at least once a day. It's a minor annoyance, but I can live with it for now.

    My main issue is that when XBMC crashes (either that, or when the ATV reboots), it seems to wipe my screensaver setting back to the default (off). This is kind of a big deal for me since I'm running this on a plasma TV. If I ever fall asleep watching TV, it's a safeguard that my TV wont get ruined.

    I also try to set the sleep timer, but it's not something that I always remember to do.

    So with that said, is this a common issue? Is there a fix or workaround I can do to force it to save? Make the settings file read-only maybe? Any help is appreciated.
     
  2. maturola macrumors 68040

    maturola

    Joined:
    Oct 29, 2007
    Location:
    Atlanta, GA
    #2
    XBMC on my ATV2 is very stable, I haven't seen or read anyone having such an issues, so I don't believe it is common, it must be something else you got install on your system that mess with XBMC, either another app or maybe an XBMC addon.

    On my very personal case, XBMC had crash maybe twice since I installed, I got Hulu, LiveStreams addon and I watch movies and TVshown from my share drive, I don't have anything else installed.

    I would recommend the following,

    1) try the XBMC forums, since It seen to be that it is more like a app issue than ATV issue.

    2) Remove all the addons and apps and see if the issue still stick around until you find which one os causing the issue.
     
  3. qwerty3089 thread starter macrumors newbie

    Joined:
    Feb 10, 2012
    #3
    thanks for the advice. Maybe I will try restoring the ATV and re-jailbreaking it. I can't think of anything else I installed that would cause issues, but it's worth trying.


    thanks again.
     
  4. britbloke, May 22, 2012
    Last edited: May 22, 2012

    britbloke macrumors newbie

    Joined:
    Jul 9, 2010
    #4
    I actually have the same problem with my JB ATV2.

    It's pretty annoying to have to set the screen saver after an XBMC reboot.

    Did you manage to find a fix?

    EDIT: Found the problem on XBMC forums here.


    A simple "Yes" to this post confirmed the conflict.
     

Share This Page