jailbroken iPhone 3G makes calls but says "network not available"

Discussion in 'Jailbreaks and iOS Hacks' started by Kristin9, Nov 24, 2009.

  1. Kristin9 macrumors newbie

    Joined:
    Apr 20, 2009
    #1
    I had a previously jailbroken (with PwnageTool) iPhone 3G with a contract through AT&T. Today I jailbroke it again with PwnageTool 3.1.4. I unchecked “Activate phone” and didn’t go into DFU mode since it was already jailbroken. Everything seems great, it works, I made a phone call on it… but next to my signal strength, it does NOT indicate my network (doesn’t say AT&T, E, or 3G). When I go to settings >General >About ... next to Network it says "Not Available." What’s up? Can I fix this???
     
  2. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #2
    This is a known issue caused by running the new firmware with the old baseband. You can fix it by installing ultrasn0w on your phone (this will also unlock your phone, but that's not a problem -- you'll still be able to use all the features of your AT&T account). You could also fix it by installing the official 3.1.2 firmware so that your baseband will be updated, then re-jailbreaking. But there is really no need for that. Ultrasn0w is safe as houses.

    If you want to know the details, it was a tiny change in the way the baseband (modem firmware) reported the carrier name to the O.S. It was only a cosmetic problem.
     
  3. Kristin9 thread starter macrumors newbie

    Joined:
    Apr 20, 2009
    #3
    THANKS SO MUCH! I was worried I'd hafta ask followup questions cuz I wouldnt know what to do after I installed ultrasn0w (honestly i had to google to find out where to download it from), but immediately after installing, the network showed up.
     

Share This Page